Announcement Announcement Module
Collapse
No announcement yet.
Spring dependency not in Maven version range Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring dependency not in Maven version range

    Hello,

    If I specify the version to Spring-Context (or any other Spring dependency) in my Maven POM file as the version range [3.0,3.1), i receive the following error:

    Code:
    Couldn't find a version in [2.5.6.SEC01, 3.0.0.RELEASE, 3.0.1.RELEASE-A, 3.0.1.RELEASE, 3.0.2.RELEASE] to match range [3.0,3.1)
      org.springframework:org.springframework.context:jar:null
    Is this a maven problem or does it have to do with the versioning of Spring artifacts and that it doesn't follow the convention of A.B.C-D but A.B.C.D instead and thus version ranges are not working?

    If I replace the version range with a concrete version (say, 3.0.2.RELEASE), it works.

    Thanks,

    Florian
Working...
X