Announcement Announcement Module
Collapse
No announcement yet.
Cannot add Groovy/Grails support Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot add Groovy/Grails support

    Hi,

    I installed STS2.3.2, I then installed extensions Groovy Eclipse and Grails support.

    After restarting STS (as suggested), I can see the Grails support extension is marked as installed but I still see Groovy Eclipse as available for installation, as if it were not installed. When I try to install it, I get the message ""Groovy-Eclipse Feature" will be ignored because it is already installed.".

    I tried to uninstall both and then reinstall them both, same behavior.
    Of course, there are no entries Groovy nor Grails in the "New project" popup.

    Any clues on how to fix this?

    Installation: Ubuntu 9.10 32 bit/STS2.3.2/JDK+JRE 1.6.019

    Thanks,

    Gael.
    Last edited by Titom; Apr 17th, 2010, 03:22 PM.

  • #2
    Solved

    Hi,

    I've found the "issue"... I had STS installed on /usr/share/springsource, a folder that belongs to root. Without starting STS and installing the extensions "as root", the process screwed something in STS configuration. Probably because extensions were not installed in the STS directories but in my home folder. If you have this issue, just go to the STS installation folder and start STS using:

    $ sudo ./STS

    In order to have Grails and Groovy activated.

    Gael.

    Comment


    • #3
      Hi,

      yes, this is indeed a known issue in Eclipse' update mechanism. This is being tracked at:

      STS-734: Grails install fails in shared install environments
      https://issuetracker.springsource.com/browse/STS-734

      Regards, Christian

      Comment

      Working...
      X