Announcement Announcement Module
Collapse
No announcement yet.
OutOfMemory PermGen in STS 2.2.0 release Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • OutOfMemory PermGen in STS 2.2.0 release

    I have been trying to resolve the OutOfMemory PermGen issue that I have run into in STS 2.2.0 release


    My application has been built on JDK1.6 , OPEN JPA, Spring 3.0 with Oracle backend.

    The problem I face is that my application runs out of the PermGen every time I run my Junits. Specifically, it hangs in the middle of running junits throwing up java.lang.OutOfMemoryError: PermGen space

    The Junit test relies on Spring heavily. All our Junits extend AbstractJpaTests.




    the JVM options I am using are in the STS .ini file :
    =====================
    --vm
    D:/proj/jdk1.6.0_12/bin/javaw.exe
    -startup
    plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v2009071 5.jar
    --launcher.library
    plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.2 00.v20090519
    -product
    com.springsource.sts.ide
    --launcher.XXMaxPermSize
    256M
    -showsplash
    com.springsource.sts
    --launcher.XXMaxPermSize
    256m
    -vmargs
    -Dosgi.requiredJavaVersion=1.5
    -Xms40m
    -Xmx1024m

    =====================================

    I have tried a few suggestions that I found on various forums -

    Current STS .ini file in the installatin directory
    Min and Max JVM heap size is set to 40 and 1024m

    Updated them to 265 and 2048m
    Closed and restarted the STS eclipse, wont even start


    Kindly provide any pointers.

  • #2
    Hi,

    it seems that your STS.ini is missing the following setting:

    Code:
    -XX:MaxPermSize=256m
    Please add this to the end of the STS.ini.

    Alternatively you could download STS 2.3.2 which has this setting out of the box.

    HTH

    Christian

    Comment


    • #3
      HI Christian

      I see this in the .ini file

      --launcher.XXMaxPermSize
      256M

      Is it different from what you have suggested? Where exactly should I add it in my .ini file.

      Comment


      • #4
        yes, this is different. Please add the setting to the end of the ini file.

        Christian

        Comment

        Working...
        X