Announcement Announcement Module
Collapse
No announcement yet.
Error during updating to the 2.3.2 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error during updating to the 2.3.2

    In the current installation 2.3.0, run the help->check for updates and get the following error:
    Code:
    The operation cannot be completed.  See the details.
    ...
    
    Cannot complete the install because one or more required items could not be found.
      Software being installed: SpringSource Tool Suite 2.3.2.201003230009-RELEASE (com.springsource.sts.ide 2.3.2.201003230009-RELEASE)
      Missing requirement: SpringSource Tool Suite Package 2.3.2.201003230009-RELEASE (com.springsource.sts.package.feature.group 2.3.2.201003230009-RELEASE) requires 'org.eclipse.wst.server_adapters.feature.feature.group 0.0.0' but it could not be found
      Cannot satisfy dependency:
        From: SpringSource Tool Suite 2.3.2.201003230009-RELEASE (com.springsource.sts.ide 2.3.2.201003230009-RELEASE)
        To: com.springsource.sts.package.feature.group [2.3.2.201003230009-RELEASE]
    How to resolve this problem so that I can get the newest release. I run into quite few problems with the current installation.

  • #2
    Christian (the STS project lead) is on vacation this week and he may have a better answer for you if you want to wait, but the best that I can say is that you should download a fresh install and work from there.

    Comment


    • #3
      I had that same error at one time, so I downloaded a brand new eclipse and started from scratch.

      Also note that on the m2eclipse plugin in site that you can't update m2eclispe from 0.9.x to 0.10.0 and you must do a clean install. And STS 2.3.1 and 2.3.2 support the new 0.10.0 version where as 2.3.0 does not and supports only the earlier 0.9.x version to the best of my knowledge.

      So if your using maven in your project then you will have to get a clean installation of Eclipse and install the new STS in order to use Maven 0.10.x

      Comment


      • #4
        I just spoke with the build engineer for STS and basically, the current situation is that if you install STS from a zip, then you cannot upgrade it. However, if you install from an update site into an existing Eclipse it is possible (although not guaranteed) that you can upgrade.

        In the near future, we will be discussing work arounds that will make it possible to upgrade existing STS installs.

        Comment


        • #5
          STS 2.3.2 installation issue

          I have Windows 7 os with 32 bit.

          Now, can anybody plese tell me which STS i have to download to installed?

          Comment


          • #6
            Does the 32 bit windows version of STS not work for you?

            Comment


            • #7
              Originally posted by Andrew E View Post
              I just spoke with the build engineer for STS and basically, the current situation is that if you install STS from a zip, then you cannot upgrade it. However, if you install from an update site into an existing Eclipse it is possible (although not guaranteed) that you can upgrade.
              ....
              When you say "an existing Eclipse", you don't mean a STS is included, right? The only option I have is to remove the installation directory and reinstall STS from the zip file. That takes a long time though.

              Comment


              • #8
                Yes. You will have to download a new version of STS 2.3.2 and unzip it.

                It seems like from 2.3.2+ you will be able to upgrade to later versions via check for updates.

                Comment


                • #9
                  STS 2.3.2 installation issue

                  Originally posted by Andrew E View Post
                  Does the 32 bit windows version of STS not work for you?

                  No.

                  I have downloaded zip STS 2.3.2 version and unzip it when i run exe that shows below error:

                  "The STS executable launcher was unable to locate its companion shared library".

                  Let me know if i am doing anything wrong.

                  Comment


                  • #10
                    This problem tends to happen when the launcher jar cannot be found. The part of the launcher that cannot be found is the OS-specific launcher in a folder like plugins/org.eclipse.equinox.launcher.win32_1.0.200*.

                    Try running "STS.exe -console" from a console and see what the output is.

                    A possible workaround is to explicitly specify your the launcher library. From the command line, add this:

                    --launcher.library <full_path_to_eclipse>/plugins/org.eclipse.equinox.launcher.win32_<your_version_n umber>/<whatever>.dll

                    This option is described here: http://ppires.wordpress.com/2008/11/...update-solved/

                    If that doesn't help you, check out these pages:
                    http://ppires.wordpress.com/2008/11/...update-solved/
                    http://communities.vmware.com/thread/225601

                    Please let me know if this helps you.

                    Comment


                    • #11
                      STS Installation issue

                      Originally posted by Andrew E View Post
                      This problem tends to happen when the launcher jar cannot be found. The part of the launcher that cannot be found is the OS-specific launcher in a folder like plugins/org.eclipse.equinox.launcher.win32_1.0.200*.

                      Try running "STS.exe -console" from a console and see what the output is.

                      A possible workaround is to explicitly specify your the launcher library. From the command line, add this:

                      --launcher.library <full_path_to_eclipse>/plugins/org.eclipse.equinox.launcher.win32_<your_version_n umber>/<whatever>.dll

                      This option is described here: http://ppires.wordpress.com/2008/11/...update-solved/

                      If that doesn't help you, check out these pages:
                      http://ppires.wordpress.com/2008/11/...update-solved/
                      http://communities.vmware.com/thread/225601

                      Please let me know if this helps you.
                      Thanks for good suggestion, I am working on the same.
                      Please let me tell you again I have Windows 7 OS.

                      Comment


                      • #12
                        Thanks for reply.

                        I have installed with STS.exe(171 MB for win32) successfully but .zip has some issue.

                        I think there is some issue related to files available in zip folder.

                        Comment


                        • #13
                          Hi,

                          when installed STS on Windows you need to watch for the bit level of your OS and JDK. So if your JDK is 64bit then install STS 64bit; if your JDK is 32bit (even on 64bit Win) install STS 32bit.

                          HTH

                          Christian

                          Comment

                          Working...
                          X