Announcement Announcement Module
Collapse
No announcement yet.
Grails plugin depends on older mylyn JIRA connector Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Grails plugin depends on older mylyn JIRA connector

    When installing grails support I get the following message:
    Your original request has been modified.
    "Spring IDE Core (required)" is already installed, so an update will be performed instead.
    "Spring IDE AOP Extension (optional)" is already installed, so an update will be performed instead.
    "Spring IDE Mylyn Integration (optional)" is already installed, so an update will be performed instead.
    Cannot complete the install because one or more required items could not be found.
    Software being installed: SpringSource Tool Suite Grails Support 2.3.2.201003230009-RELEASE (com.springsource.sts.grails.feature.group 2.3.2.201003230009-RELEASE)
    Missing requirement: com.springsource.sts.ide.ui 2.3.2.201003230009-RELEASE requires 'bundle org.eclipse.mylyn.jira.core [3.3.2,3.4.0)' but it could not be found
    Cannot satisfy dependency:
    From: SpringSource Tool Suite (required) 2.3.2.201003230009-RELEASE (com.springsource.sts.feature.group 2.3.2.201003230009-RELEASE)
    To: com.springsource.sts.ide.ui [2.3.2.201003230009-RELEASE]
    Cannot satisfy dependency:
    From: SpringSource Tool Suite Grails Support 2.3.2.201003230009-RELEASE (com.springsource.sts.grails.feature.group 2.3.2.201003230009-RELEASE)
    To: com.springsource.sts.feature.group [2.3.2,2.4.0)
    MYLYN wiki contains:
    The Atlassian update site distributes a feature and plug-in that with the same bundle ids as the Mylyn JIRA Connector (org.eclipse.mylyn.jira_feature) but with a higher version (3.4.0) than the latest available release of the Mylyn JIRA Connector.
    Is this dependency to the mylyn JIRA connector really required?

    I've opened https://issuetracker.springsource.com/browse/STS-887

  • #2
    Sorry, I haven't found https://issuetracker.springsource.com/browse/STS-831

    Anyway, my question is still open: is the mylyn JIRA connector really required for development of grails apps?

    Comment

    Working...
    X