Announcement Announcement Module
No announcement yet.
Cannot upgrade from 2.3.0 to 2.3.1 Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot upgrade from 2.3.0 to 2.3.1

    I currently have STS 2.3.0.RELEASE (32-bit Linux) installed. When I try to upgrade using "Check for Updates", I get blocked with the following error:

    Cannot complete the install because one or more required items could not be found.
      Software being installed: SpringSource Tool Suite (com.springsource.sts.ide
      Missing requirement: SpringSource Tool Suite Package ( requires ' 0.0.0' but it could not be found
      Cannot satisfy dependency:
        From: SpringSource Tool Suite (com.springsource.sts.ide
        To: []
    Since it seems to be working for others, I'm guessing it's either a Linux-specific bug, or a misconfiguration of my environment. Is there a fix or workaround available?

    = Eric

  • #2
    I have the same problem on Windows so its not Linux-specific.
    Fairly standard setup:

     CollabNet Desktop - Eclipse Edition	2.0.5
        CollabNet Merge Client	2.0.1
        Subclipse (Required)	1.6.8
        Subclipse Integration for Mylyn 3.x (Optional)	3.0.0
        Subversion Client Adapter (Required)	1.6.8
        Subversion JavaHL Native Library Adapter (Required)
        Subversion Revision Graph	1.0.7
      FindBugs Feature
      GlassFish Java EE 5, Java EE 6	1.0.52
      Grails (production release)	1.2.1
      Groovy-Eclipse Feature
        JDT Core patch for Groovy-Eclipse plugin
      PMD Plug-in	3.2.6.v200903300643
      SpringSource Tool Suite	com.springsource.sts.ide
        SpringSource Tool Suite Package
      SpringSource Tool Suite Grails Support
        Spring IDE Core (required)
        SpringSource Tool Suite (required)
      StartExplorer  Feature	0.5.0
    Last edited by Jas-e; Mar 18th, 2010, 04:58 AM.


    • #3
      I was able to get around the dependency problem for oup 0.0.0 by installing (via the sts interface) the WST Server Adapters package from


      • #4
        It works

        Thanks. That seemed to work.

        I added as an update site
        Installed: WST Server Adapters 3.1.0.v200906020451
        Then did a "Check for Updates"