Announcement Announcement Module
Collapse
No announcement yet.
STS 2.3.1 only available as Update? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS 2.3.1 only available as Update?

    Hey @ll,

    just noticed that the bugtracker has the 2.3.1 version marked as "released", yet I can only find the 2.3.0 version on the download page. Is the new version only available as an update? Will there be a download sometime soon?
    *edit* only tried the zip / tar.gz downloads though, in case 2.3.1 is downloadable via the installers allow me to rephrase the question to: will there be a downloadable zip / tar.gz version */edit*

    Cheers,

    Whizz
    Last edited by whiskerz; Mar 10th, 2010, 10:48 AM.

  • #2
    I'm having problems updating:

    Code:
    Cannot complete the install because one or more required items could not be found.
      Software being installed: SpringSource Tool Suite 2.3.1.201003091003-RELEASE (com.springsource.sts.ide 2.3.1.201003091003-RELEASE)
      Missing requirement: SpringSource Tool Suite Package 2.3.1.201003091003-RELEASE (com.springsource.sts.package.feature.group 2.3.1.201003091003-RELEASE) requires 'org.eclipse.wst.server_adapters.feature.feature.group 0.0.0' but it could not be found
      Cannot satisfy dependency:
        From: SpringSource Tool Suite 2.3.1.201003091003-RELEASE (com.springsource.sts.ide 2.3.1.201003091003-RELEASE)
        To: com.springsource.sts.package.feature.group [2.3.1.201003091003-RELEASE]
    Why is this happening ?
    I've tried to install from: SpringSource Update Site for Eclipse 3.5 - http://www.springsource.com/update/e3.5

    But I'm having the same problem !

    I apreciate any help.

    Comment


    • #3
      me too

      having same problem

      Comment


      • #4
        Got one step down...

        If you install the WST Eclipse plugin from Help / Install New Software, this message is cleared. However the next one for me is about an Eclipse Mylyn plugin, so I am now tracking down the correct Mylyn plugin. And then we'll see what the next thing is it complains about...

        Comment


        • #5
          All,

          the STS 2.3.1 downloads will become available later today. Please check back this forum, springsource.org, twitter or the download page to see the notification when it becomes available.

          For an update site installation please read through the installation instructions available at: http://download.springsource.com/rel....1.RELEASE.pdf

          HTH

          Christian

          Comment


          • #6
            New groovy class issue

            Hi, I successfully updates to STS 3.2.1 also update groovy and grails features.

            When i try to create new Groovy class error occurred: org.codehaus.groovy.tools.GroovyClass.getClassNode ()Lorg/codehaus/groovy/ast/ClassNode;


            Logs:

            !ENTRY org.eclipse.jface 4 2 2010-03-11 01:09:53.250
            !MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.jface".
            !STACK 0
            java.lang.NoSuchMethodError: org.codehaus.groovy.tools.GroovyClass.getClassNode ()Lorg/codehaus/groovy/ast/ClassNode;
            at org.codehaus.jdt.groovy.internal.compiler.ast.Groo vyCompilationUnitDeclaration.generateCode(GroovyCo mpilationUnitDeclaration.java:1248)
            at org.eclipse.jdt.internal.compiler.Compiler.resolve (Compiler.java:967)
            at org.eclipse.jdt.internal.core.CompilationUnitProbl emFinder.process(CompilationUnitProblemFinder.java :190)
            at org.codehaus.jdt.groovy.model.GroovyCompilationUni t.buildStructure(GroovyCompilationUnit.java:339)
            at org.eclipse.jdt.internal.core.Openable.generateInf os(Openable.java:258)
            at org.eclipse.jdt.internal.core.JavaElement.openWhen Closed(JavaElement.java:515)
            at org.eclipse.jdt.internal.core.JavaElement.getEleme ntInfo(JavaElement.java:252)
            at org.eclipse.jdt.internal.core.JavaElement.getEleme ntInfo(JavaElement.java:238)
            at org.eclipse.jdt.internal.core.CompilationUnit.getS ourceRange(CompilationUnit.java:920)
            at org.eclipse.jdt.internal.ui.javaeditor.selectionac tions.GoToNextPreviousMemberAction.update(GoToNext PreviousMemberAction.java:90)
            at org.eclipse.jdt.internal.ui.javaeditor.selectionac tions.GoToNextPreviousMemberAction.<init>(GoToNext PreviousMemberAction.java:69)
            at org.eclipse.jdt.internal.ui.javaeditor.selectionac tions.GoToNextPreviousMemberAction.newGoToNextMemb erAction(GoToNextPreviousMemberAction.java:56)
            at org.eclipse.jdt.internal.ui.javaeditor.JavaEditor. createActions(JavaEditor.java:2718)
            at org.eclipse.jdt.internal.ui.javaeditor.Compilation UnitEditor.createActions(CompilationUnitEditor.jav a:1037)
            at org.codehaus.groovy.eclipse.editor.GroovyEditor.cr eateActions(GroovyEditor.java:673)
            at org.eclipse.ui.texteditor.AbstractTextEditor.creat ePartControl(AbstractTextEditor.java:3465)
            at org.eclipse.ui.texteditor.StatusTextEditor.createP artControl(StatusTextEditor.java:53)
            at org.eclipse.ui.texteditor.AbstractDecoratedTextEdi tor.createPartControl(AbstractDecoratedTextEditor. java:427)
            at org.eclipse.jdt.internal.ui.javaeditor.JavaEditor. createPartControl(JavaEditor.java:3078)
            at org.eclipse.jdt.internal.ui.javaeditor.Compilation UnitEditor.createPartControl(CompilationUnitEditor .java:1475)
            at org.codehaus.groovy.eclipse.editor.GroovyEditor.cr eatePartControl(GroovyEditor.java:801)
            at org.eclipse.ui.internal.EditorReference.createPart Helper(EditorReference.java:662)
            at org.eclipse.ui.internal.EditorReference.createPart (EditorReference.java:462)
            at org.eclipse.ui.internal.WorkbenchPartReference.get Part(WorkbenchPartReference.java:595)
            at org.eclipse.ui.internal.EditorReference.getEditor( EditorReference.java:286)
            at org.eclipse.ui.internal.EditorManager.findEditor(E ditorManager.java:403)
            at org.eclipse.ui.internal.WorkbenchPage.busyOpenEdit orBatched(WorkbenchPage.java:2799)
            at org.eclipse.ui.internal.WorkbenchPage.busyOpenEdit or(WorkbenchPage.java:2762)
            at org.eclipse.ui.internal.WorkbenchPage.access$11(Wo rkbenchPage.java:2754)
            at org.eclipse.ui.internal.WorkbenchPage$10.run(Workb enchPage.java:2705)
            at org.eclipse.swt.custom.BusyIndicator.showWhile(Bus yIndicator.java:70)
            at org.eclipse.ui.internal.WorkbenchPage.openEditor(W orkbenchPage.java:2701)
            at org.eclipse.ui.internal.WorkbenchPage.openEditor(W orkbenchPage.java:2685)
            at org.eclipse.ui.internal.WorkbenchPage.openEditor(W orkbenchPage.java:2676)
            at org.eclipse.jdt.internal.ui.javaeditor.EditorUtili ty.openInEditor(EditorUtility.java:374)
            at org.eclipse.jdt.internal.ui.javaeditor.EditorUtili ty.openInEditor(EditorUtility.java:178)
            at org.eclipse.jdt.ui.actions.OpenAction.run(OpenActi on.java:229)
            at org.eclipse.jdt.ui.actions.OpenAction.run(OpenActi on.java:208)
            at org.eclipse.jdt.ui.actions.SelectionDispatchAction .dispatchRun(SelectionDispatchAction.java:274)
            at org.eclipse.jdt.ui.actions.SelectionDispatchAction .run(SelectionDispatchAction.java:250)
            at org.eclipse.jdt.internal.ui.packageview.PackageExp lorerActionGroup.handleOpen(PackageExplorerActionG roup.java:373)
            at org.eclipse.jdt.internal.ui.packageview.PackageExp lorerPart$4.open(PackageExplorerPart.java:526)
            at org.eclipse.ui.OpenAndLinkWithEditorHelper$Interna lListener.open(OpenAndLinkWithEditorHelper.java:48 )
            at org.eclipse.jface.viewers.StructuredViewer$2.run(S tructuredViewer.java:842)
            at org.eclipse.core.runtime.SafeRunner.run(SafeRunner .java:42)
            at org.eclipse.core.runtime.Platform.run(Platform.jav a:888)
            at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil. java:48)
            at org.eclipse.jface.util.SafeRunnable.run(SafeRunnab le.java:175)
            at org.eclipse.jface.viewers.StructuredViewer.fireOpe n(StructuredViewer.java:840)
            at org.eclipse.jface.viewers.StructuredViewer.handleO pen(StructuredViewer.java:1101)
            at org.eclipse.jface.viewers.StructuredViewer$6.handl eOpen(StructuredViewer.java:1205)
            at org.eclipse.jface.util.OpenStrategy.fireOpenEvent( OpenStrategy.java:264)
            at org.eclipse.jface.util.OpenStrategy.access$2(OpenS trategy.java:258)
            at org.eclipse.jface.util.OpenStrategy$1.handleEvent( OpenStrategy.java:298)
            at org.eclipse.swt.widgets.EventTable.sendEvent(Event Table.java:84)
            at org.eclipse.swt.widgets.Widget.sendEvent(Widget.ja va:1003)
            at org.eclipse.swt.widgets.Display.runDeferredEvents( Display.java:3910)
            at org.eclipse.swt.widgets.Display.readAndDispatch(Di splay.java:3503)
            at org.eclipse.ui.internal.Workbench.runEventLoop(Wor kbench.java:2405)
            at org.eclipse.ui.internal.Workbench.runUI(Workbench. java:2369)
            at org.eclipse.ui.internal.Workbench.access$4(Workben ch.java:2221)
            at org.eclipse.ui.internal.Workbench$5.run(Workbench. java:500)
            at org.eclipse.core.databinding.observable.Realm.runW ithDefault(Realm.java:332)
            at org.eclipse.ui.internal.Workbench.createAndRunWork bench(Workbench.java:493)
            at org.eclipse.ui.PlatformUI.createAndRunWorkbench(Pl atformUI.java:149)
            at org.eclipse.ui.internal.ide.application.IDEApplica tion.start(IDEApplication.java:113)
            at org.eclipse.equinox.internal.app.EclipseAppHandle. run(EclipseAppHandle.java:194)
            at org.eclipse.core.runtime.internal.adaptor.EclipseA ppLauncher.runApplication(EclipseAppLauncher.java: 110)
            at org.eclipse.core.runtime.internal.adaptor.EclipseA ppLauncher.start(EclipseAppLauncher.java:79)
            at org.eclipse.core.runtime.adaptor.EclipseStarter.ru n(EclipseStarter.java:368)
            at org.eclipse.core.runtime.adaptor.EclipseStarter.ru n(EclipseStarter.java:179)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(Unknow n Source)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(Un known Source)
            at java.lang.reflect.Method.invoke(Unknown Source)
            at org.eclipse.equinox.launcher.Main.invokeFramework( Main.java:559)
            at org.eclipse.equinox.launcher.Main.basicRun(Main.ja va:514)
            at org.eclipse.equinox.launcher.Main.run(Main.java:13 11)

            Comment


            • #7
              Similar issue

              I am seeing the similar problem as antonevane.

              Comment


              • #8
                Uninstall / install

                Hi all -

                I got this same problem. The resolution for me was to uninstall the Groovy and Grails STS support and then re-install them both from the Extensions tab. You might not need to uninstall Grails STS support but I just did it anyway.

                The next problem you might have is that while Groovy files display fine GSP files do not - this was my next issue - and the resolution is to right-click on any GSP file in your Grails project and then specify that the file should be opened in the Groovy editor rather than the default text editor.

                - Josh

                Comment


                • #9
                  Sts

                  Originally posted by joshhone View Post
                  Hi all -

                  I got this same problem. The resolution for me was to uninstall the Groovy and Grails STS support and then re-install them both from the Extensions tab. You might not need to uninstall Grails STS support but I just did it anyway.

                  The next problem you might have is that while Groovy files display fine GSP files do not - this was my next issue - and the resolution is to right-click on any GSP file in your Grails project and then specify that the file should be opened in the Groovy editor rather than the default text editor.

                  - Josh
                  Thanks for reply.

                  My solution is download STS 2.3.1 and install groovy and grails extensions.

                  Comment


                  • #10
                    I installed Groovy, it was working fine. I wanted to install and use Grails. I downloaded and installed STS 2.3.1 through Eclipse update. Now the Groovy classes does not work and is giving the same error message as above. How do I resolve this error?

                    Comment


                    • #11
                      Works now

                      @joshhone Thank You. That helps.

                      Comment

                      Working...
                      X