Announcement Announcement Module
Collapse
No announcement yet.
Spring Tool Suite problems in OS X Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring Tool Suite problems in OS X

    Hi!
    I must have installed STS 2.3.0 RELEASE for x86 64bit Cocoa five times, by now. At first it works and I perform updates; installing Groovy, Grails and Roo etc. Then some hours later when wanting to start STS, things start to blow up for no reason at all. The last log message "explaining" the error looks like this:
    !SESSION 2010-03-02 22:19:53.492 -----------------------------------------------
    eclipse.buildId=2.3.0.200912171331-RELEASE
    java.version=1.6.0_17
    java.vendor=Apple Inc.
    BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US
    Framework arguments: -product com.springsource.sts.ide -keyring /Users/krizsan/.eclipse_keyring -showlocation
    Command-line arguments: -os macosx -ws cocoa -arch x86_64 -product com.springsource.sts.ide -keyring /Users/krizsan/.eclipse_keyring -showlocation

    !ENTRY com.springsource.com.amazonaws.eclipse.ec2 4 0 2010-03-02 22:19:57.944
    !MESSAGE
    !STACK 0
    java.util.zip.ZipException: error in opening zip file
    at java.util.zip.ZipFile.open(Native Method)
    at java.util.zip.ZipFile.<init>(ZipFile.java:114)
    at java.util.zip.ZipFile.<init>(ZipFile.java:131)
    at org.eclipse.osgi.framework.util.SecureAction.getZi pFile(SecureAction.java:251)
    at org.eclipse.osgi.baseadaptor.bundlefile.ZipBundleF ile.basicOpen(ZipBundleFile.java:88)
    at org.eclipse.osgi.baseadaptor.bundlefile.ZipBundleF ile.getZipFile(ZipBundleFile.java:101)
    at org.eclipse.osgi.baseadaptor.bundlefile.ZipBundleF ile.checkedOpen(ZipBundleFile.java:74)
    at org.eclipse.osgi.baseadaptor.bundlefile.ZipBundleF ile.getEntry(ZipBundleFile.java:246)
    at org.eclipse.equinox.weaving.hooks.WeavingBundleFil e.getEntry(Unknown Source)
    at org.eclipse.osgi.baseadaptor.bundlefile.BundleFile WrapperChain.getEntry(BundleFileWrapperChain.java: 44)
    at org.eclipse.osgi.baseadaptor.BaseData.getEntry0(Ba seData.java:111)
    at org.eclipse.osgi.baseadaptor.BaseData.getEntry(Bas eData.java:102)
    at org.eclipse.osgi.internal.baseadaptor.AdaptorUtil. loadManifestFrom(AdaptorUtil.java:185)
    at org.eclipse.core.runtime.internal.adaptor.EclipseS torageHook.getGeneratedManifest0(EclipseStorageHoo k.java:406)
    at org.eclipse.core.runtime.internal.adaptor.EclipseS torageHook.getGeneratedManifest(EclipseStorageHook .java:393)
    at org.eclipse.core.runtime.internal.adaptor.EclipseS torageHook.createCachedManifest(EclipseStorageHook .java:388)
    at org.eclipse.core.runtime.internal.adaptor.EclipseS torageHook.getManifest(EclipseStorageHook.java:507 )
    at org.eclipse.osgi.internal.baseadaptor.BaseStorage. loadManifest(BaseStorage.java:302)
    at org.eclipse.osgi.internal.baseadaptor.BaseStorage. readStateData(BaseStorage.java:757)
    at org.eclipse.osgi.internal.baseadaptor.BaseStorage. getStateManager(BaseStorage.java:704)
    at org.eclipse.osgi.baseadaptor.BaseAdaptor.getPlatfo rmAdmin(BaseAdaptor.java:373)
    at org.eclipse.core.runtime.internal.adaptor.EclipseA daptorHook.frameworkStart(EclipseAdaptorHook.java: 84)
    at org.eclipse.osgi.baseadaptor.BaseAdaptor.framework Start(BaseAdaptor.java:249)
    at org.eclipse.osgi.framework.internal.core.SystemBun dleActivator.start(SystemBundleActivator.java:61)
    at org.eclipse.osgi.framework.internal.core.BundleCon textImpl$1.run(BundleContextImpl.java:783)
    at java.security.AccessController.doPrivileged(Native Method)
    ...

    I also have an Eclipse Galileo installation that I use in parallel with the STS installation.
    I cannot use tools that behave like this and I certainly do not have time to install things over and over again. Is there any kind soul that can tell me what is wrong with STS?
    Thanks in advance!
Working...
X