Announcement Announcement Module
Collapse
No announcement yet.
Can't install subclipse or anything else from STS Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't install subclipse or anything else from STS

    I have a pretty basic installation of STS on my vista machine. Just played around with Roo on it. At some point I think I upgraded Roo on STS through help->install new software.

    Now I've needed to install subclipse, but no matter what I try I get the following error:
    Code:
    An error occurred while installing the items
      session context was:(profile=com.springsource.sts.ide, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Install, operand=null --> [R]org.springframework.roo.bundle 1.0.1.RELEASE, action=org.eclipse.equinox.internal.p2.touchpoint.natives.actions.CopyAction).
      I/O Error while copying C:\Program Files\SpringSource\sts-2.3.0.RELEASE\plugins\org.springframework.roo.bundle_1.0.1.RELEASE\content - see details.
      Error while copying:C:\Program Files\SpringSource\sts-2.3.0.RELEASE\plugins\org.springframework.roo.bundle_1.0.1.RELEASE\content\bin\roo.bat
    I've tried removing that roo directory (it says the bin directory can't be found) and I've tried removing that roo.bat file specifically (no effect). Any ideas on what's going on and how I can get anything installed?

    BTW, it's not just subclipse (which doesn't seem to have anything to do with Roo anyway), any install fails...

  • #2
    Hi,

    there is a known issue with the STS Extension install when installing STS into "Program Files". To work around that, please un-install the Roo bundle: open the About dialog -> Installation Details -> Select the Roo bundle -> Click uninstall.

    This should allow you to install third-party plugins again. To get up and running with Roo please download the Roo distribution from the springsource.org website and manually configure a Roo installation with STS: open the preferences -> Spring -> Roo - Click Add...

    HTH

    Christian

    Comment

    Working...
    X