Announcement Announcement Module
Collapse
No announcement yet.
Unable to install the Grails Support Extension in STS 2.3.1 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to install the Grails Support Extension in STS 2.3.1

    I get the following error when trying to enable the Grails Support Extension in STS 2.3.1:

    Cannot complete the install because one or more required items could not be found.
    Software being installed: SpringSource Tool Suite Grails Support 2.3.1.201002191751-RC1 (com.springsource.sts.grails.feature.group 2.3.1.201002191751-RC1)
    Missing requirement: SpringSource Grails Support (Core) 2.3.1.201002191751-RC1 (com.springsource.sts.grails.core 2.3.1.201002191751-RC1) requires 'bundle org.springframework.core [3.0.1.RELEASE-A,3.1.0)' but it could not be found
    Cannot satisfy dependency:
    From: SpringSource Tool Suite Grails Support 2.3.1.201002191751-RC1 (com.springsource.sts.grails.feature.group 2.3.1.201002191751-RC1)
    To: com.springsource.sts.grails.core [2.3.1.201002191751-RC1]

    Running springsource-tool-suite-2.3.0.RELEASE-e3.5.1-macosx-carbon-installer.dmg version on Snow Leopard

    Any ideas?
    Last edited by jwalsh; Feb 21st, 2010, 02:32 PM. Reason: Added Version & OS info

  • #2
    SnowLeopard Grails not installable

    Hi All!

    Same issue here; I'm going to check if I can install manually. Groovy installs fine, but grails can't be installed.

    Comment


    • #3
      Solved!!!

      Hi. You have to update spring from update site and then it runs fine.

      Regards!!!

      Comment


      • #4
        Which update site?

        Which update site?

        Comment


        • #5
          This one:

          SpringSource Update Site for Eclipse 3.5 - http://www.springsource.com/update/e3.5

          Comment


          • #6
            Still can't find...

            Thanks for the reply but on that update site I can't see anything that looks like the Spring core (i.e. something matching org.springframework.core [3.0.1.RELEASE-A,3.1.0)) anywhere and all the other things there are version 2.3.0 not 2.3.1.

            Comment


            • #7
              same error upgrading

              Same here trying to upgrade
              Version: 2.3.0.RELEASE
              Build Id: 200912171331
              from the update site.

              Comment


              • #8
                Yes, this is an issue.

                @JaimeFreire, your answer doesn't include a real solution. i.e., it doesn't work and there's nothing in your links that does work - unless you left out a number of important bits of course.

                Can someone please clarify how we really get this working? Thankyou.

                Comment


                • #9
                  Hi,

                  this should be fixed now. Somehow the extension update site was updated with bits from the 2.3.1.RC1 build which is currently being built and tested.

                  Sorry for the inconvenience.

                  Christian

                  Comment


                  • #10
                    Thanks Christian, I can confirm it now works at my end.

                    Comment

                    Working...
                    X