Announcement Announcement Module
Collapse
No announcement yet.
don't understand file encoding setting in workspace Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • don't understand file encoding setting in workspace

    Before I created any project, I set the text file encoding of the workspace to UTF-8. After that I created a grails project by using the dashbord and just clicking to "Grails Project". With that, all the nice messages property files are generated also a German one which seems to be used by magic when I run the grails application. This is true for any browser within STS and outside. Every message displays the German Umlauts like ä, ö, ü and so on as it schould.

    But when I open the messages_de.properties file with STS, the encoding seems funny. No proper display of ä, ö, ü, ... inside STS but with any editor outside like Windows Notepad or gvim it's fine.

    I'd like to understand this. I would like to edit the properties file within STS, so how should the file encoding be set?

  • #2
    Hi,

    you need to set the encoding to 'UTF-8' for the entry 'Java Properties File' which is a child of the 'Text' setting.

    Let me know if that helps.

    Christian

    Comment


    • #3
      solved

      Hi Christian,

      that was exactly what I needed.

      Cheers!
      Brigitte

      Comment

      Working...
      X