Announcement Announcement Module
Collapse
No announcement yet.
Can't update m2eclipse Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't update m2eclipse

    m2eclipse 0.10.0 is finally out now.
    I cannot update to it in STS, and I can't deinstall the bundled m2eclipse plugins to resolve the problem.

    Cannot complete the install because of a conflicting dependency.
    Software being installed: Maven issue tracking configurator for Mylyn 3.x (Optional) 0.10.0.20100209-0800 (org.maven.ide.eclipse.mylyn3.feature.feature.grou p 0.10.0.20100209-0800)
    Software currently installed: SpringSource Tool Suite 2.3.0.200912171331-RELEASE (com.springsource.sts.ide 2.3.0.200912171331-RELEASE)
    Only one of the following can be installed at once:
    Maven Embedder Bundle 0.10.0.20100209-0800 (org.maven.ide.eclipse.maven_embedder 0.10.0.20100209-0800)
    Maven Embedder Bundle 0.9.9.200912160759-maven-r885897-jetty-r11077 (org.maven.ide.eclipse.maven_embedder 0.9.9.200912160759-maven-r885897-jetty-r11077)
    Cannot satisfy dependency:
    From: SpringSource Tool Suite 2.3.0.200912171331-RELEASE (com.springsource.sts.ide 2.3.0.200912171331-RELEASE)
    To: com.springsource.sts.package.feature.group [2.3.0.200912171331-RELEASE]
    Cannot satisfy dependency:
    From: SpringSource Tool Suite Package 2.3.0.200912171331-RELEASE (com.springsource.sts.package.feature.group 2.3.0.200912171331-RELEASE)
    To: org.maven.ide.components.maven_embedder.feature.fe ature.group 0.0.0
    Cannot satisfy dependency:
    From: Maven Embedder 3.0.0.200912160759 (org.maven.ide.components.maven_embedder.feature.f eature.group 3.0.0.200912160759)
    To: org.maven.ide.eclipse.maven_embedder [0.9.9.200912160759-maven-r885897-jetty-r11077]
    Cannot satisfy dependency:
    From: Maven issue tracking configurator for Mylyn 3.x (Optional) 0.10.0.20100209-0800 (org.maven.ide.eclipse.mylyn3.feature.feature.grou p 0.10.0.20100209-0800)
    To: org.maven.ide.eclipse.maven_embedder [0.10.0,0.11.0)

  • #2
    Retested with a freshly installed STS 2.3.0.RELEASE:

    Your original request has been modified.
    "Maven Integration for Eclipse (Required)" is already installed, so an update will be performed instead.
    Cannot complete the install because of a conflicting dependency.
    Software being installed: Maven Integration for Eclipse (Required) 0.10.0.20100209-0800 (org.maven.ide.eclipse.feature.feature.group 0.10.0.20100209-0800)
    Software currently installed: SpringSource Tool Suite 2.3.0.200912171331-RELEASE (com.springsource.sts.ide 2.3.0.200912171331-RELEASE)
    Only one of the following can be installed at once:
    Maven Integration for Eclipse (Editors) 0.9.8.200905041414 (org.maven.ide.eclipse.editor 0.9.8.200905041414)
    Maven Integration for Eclipse (Editors) 0.10.0.20100209-0800 (org.maven.ide.eclipse.editor 0.10.0.20100209-0800)
    Cannot satisfy dependency:
    From: SpringSource Tool Suite 2.3.0.200912171331-RELEASE (com.springsource.sts.ide 2.3.0.200912171331-RELEASE)
    To: com.springsource.sts.package.feature.group [2.3.0.200912171331-RELEASE]
    Cannot satisfy dependency:
    From: SpringSource Tool Suite Package 2.3.0.200912171331-RELEASE (com.springsource.sts.package.feature.group 2.3.0.200912171331-RELEASE)
    To: org.maven.ide.eclipse.editor.feature.feature.group 0.0.0
    Cannot satisfy dependency:
    From: Maven POM Editor (Optional) 0.9.8.200905041414 (org.maven.ide.eclipse.editor.feature.feature.grou p 0.9.8.200905041414)
    To: org.maven.ide.eclipse.editor [0.9.8.200905041414]
    Cannot satisfy dependency:
    From: Maven Integration for Eclipse (Required) 0.10.0.20100209-0800 (org.maven.ide.eclipse.feature.feature.group 0.10.0.20100209-0800)
    To: org.maven.ide.eclipse.editor [0.10.0.20100209-0800]

    Comment


    • #3
      robertoschwald,

      updating m2eclipse inside STS is currently not possible.

      We'll update STS shortly to bundle latest m2eclipse but there are a bunch of issues that need to be solved first.

      Christian

      Comment


      • #4
        Roberto,

        in case you want to play around with STS and m2eclipse 0.10 in the mean time, you can find info on installing STS from scratch (based on eclipse jee download) here:
        http://dist.springsource.com/release....0.RELEASE.pdf

        That way you can leave out m2eclipse 0.9.8 and use 0.10. But no guarantee it'll work. NOTE: m2eclipse 0.10 is bundled with Maven 3 alpha6 by default - meaning it's not beta, yet!

        Have fun, ;-)
        Alex

        Comment


        • #5
          +1. I heavily second this request. Can't wait for m2eclipse 0.10 on my STS. :-)

          Comment


          • #6
            Yes, please let us update m2e ASAP

            The incremental build and performance increases will really help productivity.

            Comment


            • #7
              +1 vote. We need it.
              Do you have a JIRA issue or a plan when the next STS release with m2eclipse 0.10.0 will be available?

              thanks,
              Yanke

              Comment


              • #8
                All,

                STS 2.3.1 will come with m2eclipse 0.10.0 (incl. AJDT integration). I'm planning to do the release shortly after the Eclipse 3.5.2 the week after next.

                Regards, Christian

                Comment


                • #9
                  Because Sonatype shut down the old update site for m2eclipse there is currently no way to install the m2eclipse subclipse support into a fresh installation of STS.

                  Comment


                  • #10
                    I found this thread while googling for solutions to a similar install problem with m2eclipse 0.10. I'm not particularly thrilled about this release so I did the next best thing: try to find where the hell they put the older update site. So, for the folks that just want to keep using m2eclipse 0.9.8, here it is:

                    http://m2eclipse.sonatype.org/sites/archives/older/

                    Comment


                    • #11
                      Originally posted by Christian Dupuis View Post
                      All,

                      STS 2.3.1 will come with m2eclipse 0.10.0 (incl. AJDT integration). I'm planning to do the release shortly after the Eclipse 3.5.2 the week after next.

                      Regards, Christian
                      Hi Christian,

                      any news about when the new bundle will be released? any problem?

                      thanks,
                      yanke

                      Comment


                      • #12
                        I am trying to download the release instructions pdf, but I get an access denied message.
                        Is this document available somewhere public?

                        Thanks
                        Sharon

                        Comment


                        • #13
                          Hi Sharon,

                          please try the following link: http://dist.springsource.com/release....0.RELEASE.pdf

                          HTH

                          Christian

                          Comment


                          • #14
                            Hi,
                            I can't install STS on top of fresh indigo with m2e - Maven Integration for Eclipse 1.0.0.201106052308 org.eclipse.m2e.feature.feature.group Eclipse.org - m2e. It says
                            Cannot complete the install because one or more required items could not be found.
                            Software currently installed: Shared profile 1.0.0.1309518921317 (SharedProfile_epp.package.jee 1.0.0.1309518921317)
                            Missing requirement: Shared profile 1.0.0.1309518921317 (SharedProfile_epp.package.jee 1.0.0.1309518921317) requires 'org.maven.ide.eclipse [1.0.0.201106052308]' but it could not be found
                            Do I understand correctly that it's the same problem as described in the begging of this thread - a 'hardcoded' version of m2eclipse dependency? But now STS needs exactly 0.10 so new 1.0 doesn't fit it?

                            Best regards, Eugene.

                            Comment


                            • #15
                              I have the same issue.

                              I did end up being able to install it after getting rid of a bunch of stuff, but now it won't let me install any other plugins:

                              Cannot complete the install because one or more required items could not be found.
                              Software currently installed: Shared profile 1.0.0.1311302631027 (SharedProfile_com.springsource.sts.ide 1.0.0.1311302631027)
                              Missing requirement: Shared profile 1.0.0.1311302631027 (SharedProfile_com.springsource.sts.ide 1.0.0.1311302631027) requires 'org.maven.ide.eclipse [1.0.0.20110607-2117]' but it could not be found

                              Comment

                              Working...
                              X