Announcement Announcement Module
Collapse
No announcement yet.
Problem with <sec:intercept-methods> in configuration editor Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with <sec:intercept-methods> in configuration editor

    I have a context configuration file like this
    ------------------
    <beans xmlns="http://www.springframework.org/schema/beans"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xmlns:cxf="http://cxf.apache.org/core"
    xmlns:jaxws="http://cxf.apache.org/jaxws"
    xmlns:sec="http://www.springframework.org/schema/security"
    xsi:schemaLocation="http://www.springframework.org/schema/beans http://www.springframework.org/schem...-beans-2.5.xsd
    http://cxf.apache.org/core http://cxf.apache.org/schemas/core.xsd
    http://cxf.apache.org/jaxws http://cxf.apache.org/schemas/jaxws.xsd
    http://www.springframework.org/schema/security http://www.springframework.org/schema/security/spring-security-2.0.xsd">
    ...
    <bean id="vpwService" class="se.cybercom.heba.hsa.vpw.services.impl.VpwH saServiceImpl">
    <property name="hsaVpwDao" ref="vpwDao" />
    <property name="hsaService" ref="hsaService" />
    <sec:intercept-methods>
    <secrotect method="getVpwPublicUnits" access="ROLE_VPW" />
    <secrotect method="getVpwHsaUnit" access="ROLE_VPW" />
    </sec:intercept-methods>
    </bean>
    ...
    <bean id="hsaWsImpl" class="se.cybercom.heba.svr.ws.HsaWsResponderInter faceImpl">
    <property name="vpwHsaService" ref="vpwService"/>
    ...
    </bean>
    ...
    </beans>
    --------------------------------------
    In the context editor I get a warning on hsaWsImpl bean that it can't find referenced bean vpwService. The vpwService bean is there as you may see. I also don't see the vpwService bean in the bean graph.

    If I remove <sec:intercept-methods> from vpwService then the warning disappears and vpwService appears in the bean graph.

    Anyone have an idea what could be wrong? I'm using STS 2.3.0.
Working...
X