Announcement Announcement Module
Collapse
No announcement yet.
STS says "synchronized", but it isn't Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • vw729
    started a topic STS says "synchronized", but it isn't

    STS says "synchronized", but it isn't

    After updated JSP files, I did "Run As" -> Maven clean, "Run As" -> Maven install and "Run As" -> Run On Server. Beside the application name, STS says the application is synchronized. But, the JSP files are old version. Only usage problem I can think of is the JSP file location. I have them under the src/main/webapp/WEB-INF/. My development directory structure is the same as the petcare sample.

    Can someone tell me the cause?

    Thanks.

  • vw729
    replied
    Originally posted by Christian Dupuis View Post

    what is your deployment target? Are you deploying to tc Server?
    Thanks very much Christian for your response. I don't know how to answer your first question. I copied over the petcare sample including the pom file and replaced anythings needed. For your second question, yes, I deploy with the Spring TC server which come with STS.

    Originally posted by Christian Dupuis View Post

    Please make sure that you have "Build Automatically" from Project menu enabled.

    Christian
    I try "Build Automatically" (that is to check "Build Automatically" under the Project menu). And "Run As" -> Run On Server. The file directories of the project are on the server, but all class files except one directory are absent.

    Leave a comment:


  • Christian Dupuis
    replied
    Hi vw729,

    what is your deployment target? Are you deploying to tc Server?

    Please don't use any of the Maven commands when deploying to any server. Whenever you changed a JSP just leave it with that and check if the server reflects the change.

    Please make sure that you have "Build Automatically" from Project menu enabled.

    Christian

    Leave a comment:

Working...
X