Announcement Announcement Module
Collapse
No announcement yet.
STS Install Issues with Eclipse 3.5.1 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS Install Issues with Eclipse 3.5.1

    I am getting the following error when trying to install the STS plugin to Eclipse 3.5.1

    Cannot complete the install because one or more required items could not be found.
    Software being installed: SpringSource Tool Suite Package 2.3.1.201002010802-CI-R4529-B108 (com.springsource.sts.package.feature.group 2.3.1.201002010802-CI-R4529-B108)
    Missing requirement: SpringSource Tool Suite Package 2.3.1.201002010802-CI-R4529-B108 (com.springsource.sts.package.feature.group 2.3.1.201002010802-CI-R4529-B108) requires 'org.eclipse.equinox.weaving.feature.group 0.0.0' but it could not be found

    I followed directions on the following site:

    http://blog.springsource.com/2009/06...to-eclipse-35/

    I got stuck on step 8 installing "SpringSource Tool Suite Update Site"

    I ran into many dependency issues for various components and add to install a bunch of things. I had to install the following plugins to make things work:

    -AJDT
    -GEF
    -SubEclipse
    -m2eclipse
    -Mylyn for Eclipse (left out C++ package)
    -Mylyn Extras
    -PMD
    -Groovy Eclipse
    -Spring IDE Update Site

    Any help on this would be greatly appreciated.

  • #2
    Otto,

    please don't install the "SpringSource Tool Suite Package" feature as this is only meant to get installed for the full distribution. It contains the launchers and branding.

    Let me know if the installation works with the package feature.

    Christian

    Comment


    • #3
      Only required components

      I've tried installing STS only with the required components. This also doesn't work:

      Cannot complete the install because one or more required items could not be found.
      Software being installed: SpringSource Tool Suite (required) 2.3.0.200912171331-RELEASE (com.springsource.sts.feature.group 2.3.0.200912171331-RELEASE)
      Missing requirement: com.springsource.sts.ide.ui 2.3.0.200912171331-RELEASE requires 'bundle org.eclipse.ajdt.ui 0.0.0' but it could not be found
      Cannot satisfy dependency:
      From: Spring Configuration Editor UI 2.3.0.200912171331-RELEASE (com.springsource.sts.config.ui 2.3.0.200912171331-RELEASE)
      To: bundle com.springsource.sts.ide.ui 0.0.0
      Cannot satisfy dependency:
      From: SpringSource Tool Suite (required) 2.3.0.200912171331-RELEASE (com.springsource.sts.feature.group 2.3.0.200912171331-RELEASE)
      To: com.springsource.sts.config.ui [2.3.0.200912171331-RELEASE]

      Comment

      Working...
      X