Announcement Announcement Module
Collapse
No announcement yet.
STS Installation problem on Eclipse 3.5 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS Installation problem on Eclipse 3.5

    When I try to install the last step as explained at (http://blog.springsource.com/2009/06...to-eclipse-35/) in the Installation I am getting following error any solution please let me know.
    Regards,
    Lalit
    -----------
    Cannot complete the install because one or more required items could not be found.
    Software being installed: SpringSource Tool Suite (required) 2.3.1.201002020801-CI-R4541-B109 (com.springsource.sts.feature.group 2.3.1.201002020801-CI-R4541-B109)
    Missing requirement: SpringSource Tool Suite (required) 2.3.1.201002020801-CI-R4541-B109 (com.springsource.sts.feature.group 2.3.1.201002020801-CI-R4541-B109) requires 'org.eclipse.mylyn_feature.feature.group [3.3.2.I20100126,3.4.0)' but it could not be found

  • #2
    I see the same problem

    I'm seeing the same thing, with a completely fresh installation of Eclipse 3.5 and following the instructions here: http://blog.springsource.com/2009/06...to-eclipse-35/

    Comment


    • #3
      Hi,

      to install the nightly versions of STS you need to add the weekly build update site for Mylyn:

      * http://download.eclipse.org/tools/my...te/weekly/e3.4
      * http://download.eclipse.org/tools/my.../weekly/extras

      Please install all features from the first (not including the support for C development) and the JIRA connector from the extras site.

      I'll update the blog post with this more recent information.

      Christian

      Comment


      • #4
        Hi,
        I've the same problem as the other users. I added the weekly build update site for Mylyn as you suggest, and installed the suggested features, but I'm still having the same error:

        Missing requirement: SpringSource Tool Suite (required) 2.3.1.201002030805-CI-R4571-B110 (com.springsource.sts.feature.group 2.3.1.201002030805-CI-R4571-B110) requires 'org.eclipse.mylyn.commons.net [3.3.2.I20100126,4.0.0)' but it could not be found


        Francesco

        Comment


        • #5
          Francesco,

          this error is due to some erroneous dependency meta data in STS' nightly build. This will be fixed in tomorrow's nightly build.

          Christian

          Comment


          • #6
            If we get a new build of STS tomorrow that would be great.

            I got around the problem by installing Mylyn for Eclipse (couldn't install C++ package so left that one out).

            It got me through that problem, but I am having other problems with the install. I basically added all the dependencies that were discovered. I got stuck on the very last step and can't figure out how to fix that one.

            Here's a link to my new thread on the issue that I'm having.

            http://forum.springsource.org/showthread.php?t=84183

            I will look for tomorrow's build.

            Thanks,

            -Otto

            Comment


            • #7
              Originally posted by Christian Dupuis View Post
              Francesco,

              this error is due to some erroneous dependency meta data in STS' nightly build. This will be fixed in tomorrow's nightly build.

              Christian
              Thanks a lot I will try to check it tomorrow again.
              Regards,
              Lalit

              Comment


              • #8
                A different error message this time

                I know I need to check it tomorrow. But I just thought of giving it a try and I got a different error this time.
                ----------------------
                Cannot complete the install because one or more required items could not be found.
                Software being installed: SpringSource Tool Suite Tutorials 2.3.1.201002040802-CI-R4589-B111 (com.springsource.sts.tutorials.feature.group 2.3.1.201002040802-CI-R4589-B111)
                Missing requirement: com.springsource.sts.ide.ui 2.3.1.201002040802-CI-R4589-B111 requires 'bundle org.eclipse.mylyn.tasks.ui [3.3.2,4.0.0)' but it could not be found
                Cannot satisfy dependency:
                From: SpringSource Tool Suite Tutorials 2.3.1.201002040802-CI-R4589-B111 (com.springsource.sts.tutorials.feature.group 2.3.1.201002040802-CI-R4589-B111)
                To: com.springsource.sts.ide.ui 0.0.0

                Comment


                • #9
                  Hi mohanlalit,

                  you need to install the Mylyn weekly build before attempting to install STS. Please see my comment at http://forum.springsource.org/showpo...39&postcount=3.

                  HTH

                  Christian

                  Comment


                  • #10
                    Dear Christian,
                    I tried again as you explained. Even I tried to install every thing again and I got this error.
                    I have followed every single step as explained in your blog.
                    Regards,
                    Lalit
                    -------------------------
                    Cannot complete the install because one or more required items could not be found.
                    Software being installed: SpringSource Tool Suite (required) 2.3.1.201002050810-CI-R4605-B112 (com.springsource.sts.feature.group 2.3.1.201002050810-CI-R4605-B112)
                    Missing requirement: SpringSource Tool Suite (required) 2.3.1.201002050810-CI-R4605-B112 (com.springsource.sts.feature.group 2.3.1.201002050810-CI-R4605-B112) requires 'org.eclipse.mylyn.context_feature.feature.group [3.3.2.I20100126,3.4.0)' but it could not be found

                    Comment


                    • #11
                      mohanlalit,

                      it seems that you don't have the Mylyn weekly build installed that is required. Please install it all features (expect the C++ support) from the following two update sites and then try to install STS again.

                      * http://download.eclipse.org/tools/my...te/weekly/e3.4
                      * http://download.eclipse.org/tools/my.../weekly/extras

                      Christian

                      Comment


                      • #12
                        Dear Christian,
                        This time I got this new message.
                        Regards,
                        Lalit


                        -----------
                        Cannot complete the install because one or more required items could not be found.
                        Software being installed: SpringSource Tool Suite Grails Support 2.3.1.201002050810-CI-R4605-B112 (com.springsource.sts.grails.feature.group 2.3.1.201002050810-CI-R4605-B112)
                        Missing requirement: SpringSource Grails Support (Core) 2.3.1.201002050810-CI-R4605-B112 (com.springsource.sts.grails.core 2.3.1.201002050810-CI-R4605-B112) requires 'bundle org.codehaus.groovy 0.0.0' but it could not be found
                        Cannot satisfy dependency:
                        From: SpringSource Tool Suite Grails Support 2.3.1.201002050810-CI-R4605-B112 (com.springsource.sts.grails.feature.group 2.3.1.201002050810-CI-R4605-B112)
                        To: com.springsource.sts.grails.core [2.3.1.201002050810-CI-R4605-B112]

                        Comment


                        • #13
                          mohanlalit,

                          if you select the Grails feature when installing STS you need to also add the Groovy-Eclipse update site to your Eclipse update manager. To do so, please add http://dist.springsource.org/release/GRECLIPSE/e3.5/.

                          Please note that the instructions on my blog are outdated and I'm currently working on getting a new version up.

                          HTH

                          Christian

                          Comment


                          • #14
                            Thanks a lot Christian,
                            I was finally able to install every thing.
                            Regards,
                            Lalit

                            Comment


                            • #15
                              auto plugin install fails, tooo long plugin pathnames

                              dudes,

                              I also have problems with installation - especially with installing SVN plugins..

                              The path+filenames of the plugin files are more than 255 chars and Windows Explorer cannot browse them.
                              I'm OK for that, but looks like that this (or some similar) restriction screws the plugin installation too..

                              Comment

                              Working...
                              X