Announcement Announcement Module
Collapse
No announcement yet.
Problems integrating Grails support Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems integrating Grails support

    Dear Community,

    perhaps you can help me:

    I've a problem installing the Grails support into SpringSource Tool Suite.

    When I go to 'dashboard'-> 'Extensions' -> 'Languages and Frameworks' and click
    'Grails (current production release)' -> 'Install' and accept the Licence Agreements, start to install, the routine stops with the message:

    'Install' has encountered a problem.
    An error occurred while installing the items.

    Looking at details gives me:

    An error occurred while installing the items
    session context was:\(profile=com.springsource.sts.ide, phase=org.eclipse.equinox.internal.provisional.p2. engine.phases.Install, operand=null --> [R]org.codehaus.grails.bundle 1.2.0, action=org.eclipse.equinox.internal.p2.touchpoint. natives.actions.CopyAction).
    I/O Error while copying C:\Program Files\SpringSource\sts-2.3.0.RELEASE\plugins\org.codehaus.grails.bundle_1 .2.0\content - see details.
    Source: C:\Program Files\SpringSource\sts-2.3.0.RELEASE\plugins\org.codehaus.grails.bundle_1 .2.0\contentdoes not exists

    What is the problem?

    On the system grails is already installed, perhaps this is the cause?

  • #2
    altmann,

    I'm not sure why this installation failed on you. I just tried it myself and it all worked fine here. Can you please retry.

    Do you want to install the Grails Framework or the tooling support for Groovy & Grails? If you want to get the tools, select the "Groovy Eclipse" and "Grails Support" entries on the Extension install.

    Let me know if that helps.

    Christian

    Comment


    • #3
      Thank you Christian for your fast reply.

      No, I want to integrate both. Only the installation of 'Grails Support' worked fine.

      Going on 'Groovy Support'-> 'install', shows me in the Install-Screen section Details: 'Cannot complete the request. See the error log for details.
      "Groovy-Eclipse Feature" will be ignored because it is already installed.'
      And I cannot go further.
      This according to the section 'Language and Framework Support'.
      However, installing 'Language and Framework' -> 'Grails (current production release' gives me the described error from the last post.

      I have already installed Grails in the Command Line (working in MS Vista), perhaps this entails the error

      Comment


      • #4
        Hmm,

        in this case I think you are all start and can start to begin using Groovy and Grails features in your STS. Can you verify that you have "New Groovy Project" and "New Grails Project" in your File -> New ... -> Project ... menu?

        This will confirm that all the installation went ok.

        To configure your external Grails install from Window -> Preferences - Groovy -> Grails.

        Let me know if that helps.

        Christian

        Comment


        • #5
          Hi,

          thank you Christian,

          i've deleted the installation of Springsource Tool Suite,
          installed the latest JDK 18,
          reinstalled STS,
          installed Grails Framework Support and Groovy Framework Support,
          looked for New Project -> New Grails Project / Groovy Project

          and now it works! :-)

          Don't know why not in the first installation

          Best Regards

          Comment

          Working...
          X