Announcement Announcement Module
Collapse
No announcement yet.
STS 2.3.0, HTTP server doesn't work for static web project Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS 2.3.0, HTTP server doesn't work for static web project

    I created a simple static web project, added some htm files under WebContent, and set the context root to 'abc'.

    I went to the server tab, did a
    new -> server
    Basic -> HTTP Server
    Click Next (Defaults for HTTP Port and URL Prefix in empty)
    Click Next
    Select available resource and add it to 'Configured'
    Click Finish

    Right clicked on a static web project and selected Properties
    Click on Server
    Select the HTTP server that I just created.
    Click OK

    Right click on index.htm (very simple html) Run As -> Run On Server.
    The documentation stated that a wizard should come up to select the
    server that you want to use and to add the web project. The wizard never
    came up. But I set the server through the project properties -> Server.


    A new tab pane is created with an error.
    'Navigation to the webpage was canceled

    I bring up an instance of Firefox
    enter http://localhost/abc/index.htm
    And get a 'Cannot connect' error.

    The HTTP server is in the 'Started, Synchronized' state
    It appears that the htm files have not been deployed...

    I must be overlooking something. This should be a very simple thing to do...
Working...
X