Announcement Announcement Module
Collapse
No announcement yet.
Unable to Install STS Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to Install STS

    Hi,


    I am having trouble in installing the STS on eclipse 3.5. Please see the error message. I followed the instructions posted on Christian Dupuis blog (http://blog.springsource.com/2009/06...to-eclipse-35/).

    Regards,
    km.
    --
    Cannot complete the install because one or more required items could not be found.
    Software being installed: SpringSource Tool Suite Package 2.3.1.201001130806-CI-R4422-B86 (com.springsource.sts.package.feature.group 2.3.1.201001130806-CI-R4422-B86)
    Missing requirement: SpringSource Tool Suite Package 2.3.1.201001130806-CI-R4422-B86 (com.springsource.sts.package.feature.group 2.3.1.201001130806-CI-R4422-B86) requires 'org.maven.ide.eclipse.feature.feature.group 0.0.0' but it could not be found

  • #2
    Installing STS into an existing Eclipse 3.5 install is always a bit tricky. This is because your current version of Eclipse may require certain dependencies (from installed plugins) that conflict with the dependencies that STS uses. If the following doesn't work, then the best I could suggest is downloading the STS binaries and just starting from scratch.

    Try this:
    • Ensure that "Contact all update sites..." is checked in your update manager
    • If that doesn't work, uninstall the maven integration and svn integration from your Eclipse and try again.

    Comment

    Working...
    X