Announcement Announcement Module
Collapse
No announcement yet.
Cannot create dm server in STS Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot create dm server in STS

    Hello!

    I tried to follow the doc "Creating an Application with dm Server" for the 2.0.0.RC1 DM server and got stuck by the section "Configuring dm Server target runtime".

    It tells: "In the New Server dialog, choose SpringSource → SpringSource dm Server v2.0 and click Next."

    Now the problem is that there is no "SpringSource dm Server v2.0" option among the servers. There is tcserver, tcserver on AWS, CloudFoundry, but no dmserver. I installed all the dmserver related plugins:

    SpringSource dm Server Tools (required) 2.2.0.200910161205-SR01
    SpringSource Tool Suite dm Server Tools 2.2.0.200910161543-RC2
    SpringSource dm Server Tools Developer Resources 2.2.0.200910161205-SR01

    What could be the problem?

  • #2
    Hi,

    I can't really tell what is causing this, but since your versions of STS and dm Server Tools do not support dm Server 2.0.0.RC1 I would recommend to upgrade to STS 2.3.0.

    You should also install the latest nightly snapshot of dm Server Tools into STS 2.3.0 to get better support for the RC1 of dm Server.

    Regards, Christian

    Comment


    • #3
      Originally posted by Christian Dupuis View Post
      Hi,

      I can't really tell what is causing this, but since your versions of STS and dm Server Tools do not support dm Server 2.0.0.RC1 I would recommend to upgrade to STS 2.3.0.

      You should also install the latest nightly snapshot of dm Server Tools into STS 2.3.0 to get better support for the RC1 of dm Server.

      Regards, Christian
      How can I do that? I used the update site http://www.springsource.com/milestone/e3.5 and got all plugins form there. Also while I understand that this does not support dmserver 2.0 at least dmserver 1.0 should show up on the list, doesn't it?

      Also, I cannot create "Bundle Project" projects, because they do not show up on the list in the "New..." menu. It looks for me that somehow the dmserver support is not working in my eclipse installation.

      Comment


      • #4
        Well, I upgraded to 2.3 (took almost 2 hours to solve conflicts) and now there is a dm server adapter, but when I click the Next button after choosing the adapter, nothing happens!

        Comment

        Working...
        X