Announcement Announcement Module
Collapse
No announcement yet.
Cannot update STS to 3.5.1 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot update STS to 3.5.1

    I can't update to STS 3.5.1. I get the following error message:

    Code:
    An error occurred while collecting items to be installed
    session context was:(profile=DefaultProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
    No repository found containing: osgi.bundle,com.vmware.vfabric.ide.eclipse.tcserver.core,3.5.1.201404300755-RELEASE
    No repository found containing: osgi.bundle,com.vmware.vfabric.ide.eclipse.tcserver.insight.ui,3.5.1.201404300755-RELEASE
    No repository found containing: osgi.bundle,com.vmware.vfabric.ide.eclipse.tcserver.livegraph,3.5.1.201404300755-RELEASE
    No repository found containing: osgi.bundle,com.vmware.vfabric.ide.eclipse.tcserver.reloading,3.5.1.201404300755-RELEASE
    No repository found containing: osgi.bundle,com.vmware.vfabric.ide.eclipse.tcserver.ui,3.5.1.201404300755-RELEASE
    No repository found containing: osgi.bundle,net.sourceforge.eclipsejetty.launcher,3.7.0
    No repository found containing: osgi.bundle,org.aspectj.ajde,1.8.0.20140417150000
    No repository found containing: osgi.bundle,org.aspectj.runtime,1.8.0.20140417150000
    No repository found containing: osgi.bundle,org.aspectj.runtime.source,1.8.0.20140417150000
    No repository found containing: osgi.bundle,org.aspectj.weaver,1.8.0.20140417150000
    No repository found containing: osgi.bundle,org.eclipse.ajdt.core,2.2.4.e43yJ8-20140424-0000
    No repository found containing: osgi.bundle,org.eclipse.ajdt.doc.user,2.2.4.e43yJ8-20140424-0000
    No repository found containing: osgi.bundle,org.eclipse.ajdt.examples,2.2.4.e43yJ8-20140424-0000
    No repository found containing: osgi.bundle,org.eclipse.ajdt.mylyn.ui,2.2.0.e43yJ8-20140424-0000
    No repository found containing: osgi.bundle,org.eclipse.ajdt.ui,2.2.4.e43yJ8-20140424-0000
    No repository found containing: osgi.bundle,org.eclipse.aspectj,2.2.4.e43yJ8-20140424-0000
    No repository found containing: osgi.bundle,org.eclipse.contribution.visualiser,2.2.4.e43yJ8-20140424-0000
    No repository found containing: osgi.bundle,org.eclipse.contribution.weaving.jdt,2.2.4.e43yJ8-20140424-0000
    No repository found containing: osgi.bundle,org.eclipse.contribution.xref.core,2.2.4.e43yJ8-20140424-0000
    No repository found containing: osgi.bundle,org.eclipse.contribution.xref.ui,2.2.4.e43yJ8-20140424-0000
    No repository found containing: osgi.bundle,org.eclipse.egit,3.2.0.201312181205-r
    No repository found containing: osgi.bundle,org.eclipse.egit.core,3.2.0.201312181205-r
    No repository found containing: osgi.bundle,org.eclipse.egit.doc,3.2.0.201312181205-r
    No repository found containing: osgi.bundle,org.eclipse.egit.github.core,3.2.0.201312181205-r
    No repository found containing: osgi.bundle,org.eclipse.egit.mylyn.ui,3.2.0.201312181205-r
    No repository found containing: osgi.bundle,org.eclipse.egit.ui,3.2.0.201312181205-r
    No repository found containing: osgi.bundle,org.eclipse.jgit,3.2.0.201312181205-r
    No repository found containing: osgi.bundle,org.eclipse.mylyn.github.core,3.2.0.201312181205-r
    No repository found containing: osgi.bundle,org.eclipse.mylyn.github.doc,3.2.0.201312181205-r
    No repository found containing: osgi.bundle,org.eclipse.mylyn.github.ui,3.2.0.201312181205-r
    No repository found containing: osgi.bundle,org.sonatype.m2e.egit,0.14.0.201401060023
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.ajdt.ui.visualiser,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.ajdt.ui.xref,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.aop.core,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.aop.mylyn,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.aop.ui,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.aop.ui.matcher,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.batch,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.beans.core,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.beans.core.autowire,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.beans.core.metadata,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.beans.mylyn,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.beans.ui,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.beans.ui.autowire,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.beans.ui.editor,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.beans.ui.graph,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.beans.ui.livegraph,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.beans.ui.refactoring,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.beans.ui.search,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.bestpractices,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.boot,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.config.core,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.config.graph,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.config.ui,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.core,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.data.core,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.doc,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.integration,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.maven,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.metadata,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.mylyn,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.quickfix,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.security,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.uaa,3.5.1.201404300702-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.ui,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.webflow.core,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.webflow.mylyn,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.webflow.ui,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.webflow.ui.editor,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.webflow.ui.graph,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.wizard,3.5.1.201404300732-RELEASE
    No repository found containing: osgi.bundle,org.springsource.ide.eclipse.commons.browser,3.5.1.201404300702-RELEASE
    No repository found containing: osgi.bundle,org.springsource.ide.eclipse.commons.completions,3.5.1.201404300702-RELEASE
    No repository found containing: osgi.bundle,org.springsource.ide.eclipse.commons.configurator,3.5.1.201404300702-RELEASE
    No repository found containing: osgi.bundle,org.springsource.ide.eclipse.commons.content.core,3.5.1.201404300702-RELEASE
    No repository found containing: osgi.bundle,org.springsource.ide.eclipse.commons.core,3.5.1.201404300702-RELEASE
    No repository found containing: osgi.bundle,org.springsource.ide.eclipse.commons.frameworks.core,3.5.1.201404300702-RELEASE
    No repository found containing: osgi.bundle,org.springsource.ide.eclipse.commons.frameworks.ui,3.5.1.201404300702-RELEASE
    No repository found containing: osgi.bundle,org.springsource.ide.eclipse.commons.gettingstarted,3.5.1.201404300702-RELEASE
    No repository found containing: osgi.bundle,org.springsource.ide.eclipse.commons.livexp,3.5.1.201404300702-RELEASE
    No repository found containing: osgi.bundle,org.springsource.ide.eclipse.commons.quicksearch,3.5.1.201404300702-RELEASE
    No repository found containing: osgi.bundle,org.springsource.ide.eclipse.commons.ui,3.5.1.201404300702-RELEASE
    No repository found containing: osgi.bundle,org.springsource.ide.eclipse.dashboard.ui,3.5.1.201404300702-RELEASE
    No repository found containing: osgi.bundle,org.springsource.ide.eclipse.gradle.core,3.5.1.201404300713-RELEASE
    No repository found containing: osgi.bundle,org.springsource.ide.eclipse.gradle.toolingapi,3.5.1.201404300713-RELEASE
    No repository found containing: osgi.bundle,org.springsource.ide.eclipse.gradle.ui,3.5.1.201404300713-RELEASE
    No repository found containing: osgi.bundle,org.springsource.ide.eclipse.gradle.ui.taskview,3.5.1.201404300713-RELEASE
    No repository found containing: osgi.bundle,org.springsource.sts,3.5.1.201405030657-RELEASE
    No repository found containing: org.eclipse.update.feature,com.vmware.vfabric.ide.eclipse.tcserver,3.5.1.201404300755-RELEASE
    No repository found containing: org.eclipse.update.feature,com.vmware.vfabric.ide.eclipse.tcserver.insight,3.5.1.201404300755-RELEASE
    No repository found containing: org.eclipse.update.feature,net.sourceforge.eclipsejetty.feature,3.7.0
    No repository found containing: osgi.bundle,org.apache.commons.compress,1.4.1.v201301140946
    No repository found containing: org.eclipse.update.feature,org.aspectj,1.8.0.20140417150000
    No repository found containing: org.eclipse.update.feature,org.eclipse.ajdt,2.2.4.e43yJ8-20140424-0000
    No repository found containing: org.eclipse.update.feature,org.eclipse.contribution.weaving,2.2.4.e43yJ8-20140424-0000
    No repository found containing: org.eclipse.update.feature,org.eclipse.contribution.xref,2.2.4.e43yJ8-20140424-0000
    No repository found containing: org.eclipse.update.feature,org.eclipse.egit,3.2.0.201312181205-r
    No repository found containing: org.eclipse.update.feature,org.eclipse.egit.mylyn,3.2.0.201312181205-r
    No repository found containing: osgi.bundle,org.eclipse.jgit.archive,3.2.0.201312181205-r
    No repository found containing: org.eclipse.update.feature,org.eclipse.jgit,3.2.0.201312181205-r
    No repository found containing: org.eclipse.update.feature,org.eclipse.mylyn.github.feature,3.2.0.201312181205-r
    No repository found containing: org.eclipse.update.feature,org.sonatype.m2e.egit.feature,0.14.0.201401060023
    No repository found containing: org.eclipse.update.feature,org.springframework.ide.eclipse.ajdt.feature,3.5.1.201404300732-RELEASE
    No repository found containing: org.eclipse.update.feature,org.springframework.ide.eclipse.aop.feature,3.5.1.201404300732-RELEASE
    No repository found containing: org.eclipse.update.feature,org.springframework.ide.eclipse.autowire.feature,3.5.1.201404300732-RELEASE
    No repository found containing: org.eclipse.update.feature,org.springframework.ide.eclipse.batch.feature,3.5.1.201404300732-RELEASE
    No repository found containing: org.eclipse.update.feature,org.springframework.ide.eclipse.data.feature,3.5.1.201404300732-RELEASE
    No repository found containing: org.eclipse.update.feature,org.springframework.ide.eclipse.feature,3.5.1.201404300732-RELEASE
    No repository found containing: org.eclipse.update.feature,org.springframework.ide.eclipse.integration.feature,3.5.1.201404300732-RELEASE
    No repository found containing: org.eclipse.update.feature,org.springframework.ide.eclipse.maven.feature,3.5.1.201404300732-RELEASE
    No repository found containing: org.eclipse.update.feature,org.springframework.ide.eclipse.mylyn.feature,3.5.1.201404300732-RELEASE
    No repository found containing: org.eclipse.update.feature,org.springframework.ide.eclipse.security.feature,3.5.1.201404300732-RELEASE
    No repository found containing: org.eclipse.update.feature,org.springframework.ide.eclipse.uaa.feature,3.5.1.201404300702-RELEASE
    No repository found containing: org.eclipse.update.feature,org.springframework.ide.eclipse.webflow.feature,3.5.1.201404300732-RELEASE
    No repository found containing: org.eclipse.update.feature,org.springsource.ide.eclipse.commons,3.5.1.201404300702-RELEASE
    No repository found containing: org.eclipse.update.feature,org.springsource.ide.eclipse.commons.quicksearch.feature,3.5.1.201404300702-RELEASE
    No repository found containing: org.eclipse.update.feature,org.springsource.ide.eclipse.dashboard,3.5.1.201404300702-RELEASE
    No repository found containing: org.eclipse.update.feature,org.springsource.ide.eclipse.gradle.feature,3.5.1.201404300713-RELEASE
    No repository found containing: org.eclipse.update.feature,org.springsource.sts,3.5.1.201405030657-RELEASE
    No repository found containing: binary,org.springsource.sts.ide.executable.cocoa.macosx.x86_64,3.5.1.201405030657-RELEASE-e43
    No repository found containing: org.eclipse.update.feature,org.springsource.sts.package,3.5.1.201405030657-RELEASE-e43
    No repository found containing: binary,org.springsource.sts.package_root,3.5.1.201405030657-RELEASE-e43
    Any ideas?


    Best regards,
    James

  • #2
    Hey!

    This looks like a network or caching issue with the p2 repositories where the STS components are hosted. I would recommend to delete the content of the directory "p2/org.eclipse.equinox.p2.repository/cache" and try again. Maybe there is some stale data in the cache that prevents the update mechanism from finding the right components.

    HTH,
    Martin

    Comment


    • #3
      Hello Martin,

      Deleting the cache directory unfortunately did not help. Other ideas? :-)


      Best regards,
      James

      Comment


      • #4
        Hey!

        You could also try to change the update repository URL in the preferences (Preferences -> Install/Update -> Available Update Sites) from http://dist.springsource.com... to http://download.springsource.com... Maybe that helps. And what happens if you select the STS update site from the "Install New Software" dialog? Does the content show up?

        HTH,
        Martin

        Comment


        • #5
          Even both update sites were present: dist.springsource.com and download.springsource.com. I removed the dist. When selecting the update site, the content shows up in the "Install new software" dialog.

          Comment


          • #6
            Hey,

            What happens now if you try to do the "check for updates"? And if that doesn't work, you could try to install the new version manually via the "Install New Software..." dialog. STS will then update instead if install since it finds out that those components are already installed.

            HTH,
            Martin

            Comment


            • #7
              I get the same error messages "No repository found containing..." also when I try to install an already installed component. :-(

              What happens if I just run the installer of version 3.5.1 and choose the same installation directory. Will my settings be lost?

              Comment


              • #8
                Hey!

                Most of your settings are stored in the workspace, so they will not be lost if you choose to start with a fresh STS installation. Maybe there is a general network issue somewhere that prevents the update feature to work... :-(

                HTH,
                Martin

                Comment


                • #9
                  Just found a ticket with the same issue: https://issuetracker.springsource.com/browse/STS-3823
                  A fresh STS installation means re-installing all plugins again, isn't it... :-(

                  So if anyone has sudden inspirations how to solve this, please let me know... ;-)

                  Comment


                  • #10
                    Hey!

                    Yes, a fresh STS installation means re-installing all additional plugins, that is correct. However, I would recommend to use a command-line script for that, it saves a lot of time:

                    https://gist.github.com/martinlippert/5155155

                    This one is written for OSX, but I guess you can write a similar script for Windows and Linux as well. It installs the listed additional features from the mentioned update sites in one go.

                    HTH,
                    Martin

                    Comment

                    Working...
                    X