Announcement Announcement Module
Collapse
No announcement yet.
STS & GGTS 3.5.1 released Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS & GGTS 3.5.1 released

    Dear Spring Community,

    we are happy to announce a minor maintenance release of our Eclipse-based tooling today: The Spring Tool Suite (STS) 3.5.1 and the Groovy/Grails Tool Suite (GGTS) 3.5.1.

    This maintenance release includes a number of bug fixes as well as a few updates, including:
    • added Java8 support for faceted web projects
    • updated Maven Integration for Eclipse to support Java8
    • m2e-egit connector now included by default
    • Grails updated to 2.3.8
    • the Groovy 2.3 compiler now availabe from the dashboard (including early support for Grails 2.4M2 in GGTS)


    Both tool suites ship on top of the latest Eclipse Kepler SR2 release.

    To download the distributions, please go visit:Detailed new and noteworthy notes can be found here: STS/GGTS 3.5.1 New & Noteworthy

    The next version 3.6.0 is scheduled to arrive in July 2014, shortly after the Eclipse Luna (4.4) release.
    The first milestone build is scheduled to arrive in late May 2014.

    Enjoy!!!
    The STS/GGTS team

  • #2
    linux 64 4.3.2 dashboard appears to be broken.

    Comment


    • #3
      Hey!

      What exactly happens when you open the dashboard? Is there anything showing up in the Error View that could be related? And what JDK are you running STS with? As a workaround you can switch back to the old dashboard using the preference settings.

      HTH,
      Martin

      Comment


      • #4
        I downloaded STS 3.5.1 for Mac and installed to a brand new folder. Then opened and simply tried to add the Grails Support extension but it fails with the following error. Is Grails Support not available in STS? Do I have to install STS to work on Spring projects and GGTS to work on Grails projects?

        Problems occurred while performing installation: Operation details
        Operation details
        Cannot complete the install because of a conflicting dependency.
        Software being installed: Grails IDE 3.5.1.201404300715-RELEASE (org.grails.ide.eclipse.feature.group 3.5.1.201404300715-RELEASE)
        Software currently installed: Eclipse JDT (Java Development Tools) Patch with Java 8 support (for Kepler SR2) 1.0.0.v20140317-1956 (org.eclipse.jdt.java8patch.feature.group 1.0.0.v20140317-1956)
        Software currently installed: m2e - Maven Integration for Eclipse 1.4.1.20140328-1905 (org.eclipse.m2e.feature.feature.group 1.4.1.20140328-1905)
        Only one of the following can be installed at once:
        Java Development Tools Core 3.9.0.v20130604-1421 (org.eclipse.jdt.core 3.9.0.v20130604-1421)
        Java Development Tools Core 3.9.50.xx-201405030018-e43j8 (org.eclipse.jdt.core 3.9.50.xx-201405030018-e43j8)
        Object Teams Development Tooling Core 3.9.2.v_OTDT_r222_201402180730 (org.eclipse.jdt.core 3.9.2.v_OTDT_r222_201402180730)
        Java Development Tools Core 3.9.50.v20140317-1741 (org.eclipse.jdt.core 3.9.50.v20140317-1741)
        Java Development Tools Core 3.9.1.v20130905-0837 (org.eclipse.jdt.core 3.9.1.v20130905-0837)
        Object Teams Development Tooling Core 3.9.0.v_OTDT_r220_201306071800 (org.eclipse.jdt.core 3.9.0.v_OTDT_r220_201306071800)
        Java Development Tools Core 3.9.2.v20140114-1555 (org.eclipse.jdt.core 3.9.2.v20140114-1555)
        Object Teams Development Tooling Core 3.9.1.v_OTDT_r221_201309101918 (org.eclipse.jdt.core 3.9.1.v_OTDT_r221_201309101918)
        Cannot satisfy dependency:
        From: m2e - Maven Integration for Eclipse 1.4.1.20140328-1905 (org.eclipse.m2e.feature.feature.group 1.4.1.20140328-1905)
        To: org.eclipse.jdt.feature.group 3.6.0
        Cannot satisfy dependency:
        From: Grails IDE 3.5.1.201404300715-RELEASE (org.grails.ide.eclipse.feature.group 3.5.1.201404300715-RELEASE)
        To: org.codehaus.groovy.jdt.patch.feature.group 0.0.0
        Cannot satisfy dependency:
        From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.9.0.xx-201405030018-e43j8 Eclipse Java Development Tools 3.9.0.v20130605-2000 (org.eclipse.jdt.feature.group 3.9.0.v20130605-2000)
        To: org.eclipse.jdt.core [3.9.50.xx-201405030018-e43j8]
        Cannot satisfy dependency:
        From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.9.0.xx-201405030018-e43j8 Eclipse Java Development Tools 3.9.1.v20130911-1000 (org.eclipse.jdt.feature.group 3.9.1.v20130911-1000)
        To: org.eclipse.jdt.core [3.9.50.xx-201405030018-e43j8]
        Cannot satisfy dependency:
        From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.9.0.xx-201405030018-e43j8 Eclipse Java Development Tools 3.9.2.v20140221-1700 (org.eclipse.jdt.feature.group 3.9.2.v20140221-1700)
        To: org.eclipse.jdt.core [3.9.50.xx-201405030018-e43j8]
        Cannot satisfy dependency:
        From Patch: org.eclipse.jdt.java8patch.feature.group 1.0.0.v20140317-1956 Eclipse Java Development Tools 3.9.0.v20130605-2000 (org.eclipse.jdt.feature.group 3.9.0.v20130605-2000)
        To: org.eclipse.jdt.core [3.9.50.v20140317-1741]
        Cannot satisfy dependency:
        From Patch: org.eclipse.jdt.java8patch.feature.group 1.0.0.v20140317-1956 Eclipse Java Development Tools 3.9.1.v20130911-1000 (org.eclipse.jdt.feature.group 3.9.1.v20130911-1000)
        To: org.eclipse.jdt.core [3.9.50.v20140317-1741]
        Cannot satisfy dependency:
        From Patch: org.eclipse.jdt.java8patch.feature.group 1.0.0.v20140317-1956 Eclipse Java Development Tools 3.9.2.v20140221-1700 (org.eclipse.jdt.feature.group 3.9.2.v20140221-1700)
        To: org.eclipse.jdt.core [3.9.50.v20140317-1741]

        Comment


        • #5
          Hey!

          This is fixed now, thanks for reporting this. It only happened if you install the Grails component only without selecting the Groovy-Eclipse items as well. But that is fixed now.

          Thanks again!
          -Martin

          Comment


          • #6
            Cool, it works now! I am able to add the Grails support. Thanks for fixing that so quickly
            -Ed

            Comment


            • #7
              Hey!

              Glad to hear it works for you as well and thanks for letting us know.

              Cheers,
              -Martin

              Comment


              • #8
                I am trying to install GGTS 3.5.1 on linux and it just fails after this error-
                Starting Groovy-Eclipse compiler resolver. Specified compiler level: unspecified. I need help to get this resolved and get it up and running.

                Comment


                • #9
                  Did you try installing 2.2 and 2.3 Groovy compilers? If yes, are they listed as possible choices to switch in the Groovy -> Compilers preference page? What's the Eclipse version your GGTS is based on? 4.3.2? 4.4?

                  Cheers,
                  Alex
                  Last edited by aboyko; May 22nd, 2014, 09:56 AM.

                  Comment


                  • #10
                    I'm having problems with GGTS 3.5.1 release. I upgraded to Grails 2.4.0 and in GGTS I installed groovy extension for 2.3. Now some of my gsp tag libs such as <g:form or <g:message and etc are missing. They work in IntelliJ for Grails but not in GGTS. Anyone has the same problem or can suggestion a solution ? It's not like all tags are missing, some are missing and they aren't deprecated.
                    Last edited by manhooei; May 27th, 2014, 01:26 PM. Reason: when I type them manually they appear as warning with yellow underline.

                    Comment


                    • #11
                      Think it would be best if you could create a JIRA on spring's issuetracker and attach some simplified version of your Grails project because I don't seem to be able to reproduce the problem :-(

                      Comment


                      • #12
                        Aboyko, I don't have anything special in my Grails project. It's an out of the box grails app. I choose create Grails application from GGTS Project menu, choose grails 2.4 for it, and after it's created I open the index.gsp file and start typing some gsp tags such as <g:form and it doesn't show up. I will create a ticket for it I guess.

                        Comment


                        • #13
                          Hey!

                          Yes, creating a ticket for this would be great. Thanks!!!

                          Cheers,
                          -Martin

                          Comment


                          • #14
                            After installing Grails 2.4.0 and updating to Groovy 2.3.1 I can no longer create new projects or import already created ones. The problem is with creating a work-space:
                            Errors occurred during the build.
                            Errors running builder 'Java Builder' on project 'TestProject'.
                            org.codehaus.groovy.runtime.DefaultGroovyMethods.c ount(Ljava/lang/Iterable;Lgroovy/lang/ClosureLjava/lang/Number;

                            I'm on Debian 7, up to date, Java 7 and have GRAILS_HOME and GROOVY_HOME set correctly. From the command line everyting works and in NetBeans 8.0 everything works. GGTS worked with Grails 2.3.8 and the previous Groovy. It seems GGTS has a problem with Groovy. What to do?

                            Comment


                            • chrismalan
                              chrismalan commented
                              Editing a comment
                              Got it! I had to tell GGTS to use Groovy 2.3.0. The GROOVY_HOME pointing to 2.3.1 apparently conflicted with what GGTS was using.

                          • #15
                            Hey!

                            Glad to hear you got it working and thanks for letting us know.

                            Cheers,
                            -Martin

                            Comment

                            Working...
                            X