Announcement Announcement Module
Collapse
No announcement yet.
STS Grails support instllation issue Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS Grails support instllation issue

    Hi All.

    Have a problem adding Grails support to my STS.

    Steps:
    1. Installed Cocoa STS from the image springsource-tool-suite-2.2.1.RELEASE-e3.5.1-macosx-cocoa-installer.dmg
    2. Extensions tab -> Checked Groovy and Grails boxes
    3. Went through the installation, restarted Eclipse.

    Groovy support works fine, but there is no Grails support at all. No Grails project type, etc. Don't see grails support plugin installed in Eclipse and don't see it available in the Dashboard any more.

    Tried to install STS updates - didn't help.

    MacOS X 10.5.7
    No JDK or JRE changes since operation system installation. Have GROOVY_HOME and GRAILS_HOME env variables set.

    Any ideas? Will appreciate any help.

    Thanks,
    Alex

  • #2
    Hard to say what is happening here, but can you try the following:

    1. Uninstall your grails support (Spring Source Tool Suite -> About Spring Source Tool Suite -> Installation Details -> Features -> Select Grails feature and click uninstall...)

    2. Reinstall from the update manager. Use this update site: http://www.springsource.com/update/e3.5 (should already be included) and search for the grails feature.

    If this doesn't work, check the update manager again and see what the state of that grails version is.

    There are a few other things we can try, but let's see if this works first.

    Comment


    • #3
      Thanks you very much.
      Manual installation was successful.

      Best regards,
      Alex

      Comment

      Working...
      X