Announcement Announcement Module
Collapse
No announcement yet.
Poor performance from STS 2.2 and 2.3 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Poor performance from STS 2.2 and 2.3

    I've been using STS 2.2 (and now 2.3) with a number of complex workspaces, each of which has multiple projects with their own beans files. Some of these workspaces show very poor build speed under STS, but not under vanilla Eclipse.

    With STS 2.2, the build would just stick for around 5 seconds whenever I saved a java file or a beans file. With 2.3, it's just as slow, but now the progress bar message says "Loading /Projectname/path/to/my/beans.xml", which is perhaps a bit more useful.

    Something about these beans files is causing it, clearly, but they're pretty basic, nothing fancy.

    I've tried turning off all of the Spring validators and Builders in preferences, to see if any of them were slowing things up, but no change.

    Anyone got any suggests as to what I can try, or where I can look, to clear this problem?

  • #2
    Hi,

    to isolate this issue, could you take some thread dumps and attach that to a JIRA? Especially the period when it sticks at "Loading ..." is of interest.

    Also it might make sense to post the configuration file here if possible. Are you using any namespaces with your configuration file that don't ship with STS? Are you behind a firewall that prevents your STS to access the internet?

    Christian

    Comment


    • #3
      Hi Christian,

      No custom schema, no firewall. I did try setting up a local HTTP proxy and telling STS to use that, but no traffic was logged, so I don't think it's a remote schema fetch.

      What's the best way to go about getting a stack dump of STS?

      Comment


      • #4
        Hi,

        if you are running with Java 6 that would be 'jps' and 'jstack'. Another option would be to use visualvm.

        Let me know if that helps.

        Christian

        Comment


        • #5
          OK, see https://jira.springsource.org/browse/IDE-1064

          Comment


          • #6
            Agreed this is slow

            Same Maven project , unaltered runs at least 10x slower than standard eclipse version, tried the option presented here and other options here and no significant change
            Would love to stay with sts if this is going to be fixed soon but running with auto-build off is a pain and compiles provide time to get up and get a snack

            Comment


            • #7
              Hi, could you please post some threaddumps to the linked JIRA?

              That'll be helpful for finding the root cause.

              Thanks, Christian

              Comment


              • #8
                I have seen this bug before as well, I think it has to do with pre-existing projects that contain Maven builders (and/or Spring builders). What appears to be happening is the build starts, something occurs in either maven or spring that causes the autobuild to be launched again, starting with a re-index.

                If I recall correctly, the problem appeared in STS 2.2.x, and I mitigated it by moving the maven builder to the last builder in Eclipse. May have also removed it and re-added it, can't remember.

                Comment

                Working...
                X