Announcement Announcement Module
Collapse
No announcement yet.
STS & Eclipse 3.5 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS & Eclipse 3.5

    Hi,

    I have downloaded and installed STS 2.2.1. Now I am wondering how it integrates with Eclipse 3.5.

    1) is the STS installation supposed to include Eclipse as well? I am asking this question because a tutorial for Spring dm Server (located at: http://static.springsource.org/s2-dm...g-started.html) says the STS installation contains eclipse.exe. But I cannot find it as part of the STS install!

    2) What are the STS.exe and STSc.exe? I started both but didn't see anything happening.


    Thanks,
    Kamran
    Last edited by kamrans; Dec 6th, 2009, 12:18 PM.

  • #2
    re: STS & Eclipse 3.5

    Hi,

    I could figure out the problem. I had installed the 64bit version of STS since my OS is Vista 64. I believe the installation didn't go well, although the installer finished successfully.

    That is why I couldn't launch STS.exe. This morning I removed that installation and installed the 32bit version of the STS (from the zip file without the installer).

    I can now launch the STS.exe which in fact launches the Eclipse.

    Guys, I strongly suggest to use the 32bit version of STS even if you have a 64bit computer.

    Cheers,
    Kamran

    Comment


    • #3
      Kamran,

      to run STS, not only the bit level of your OS is important, but more so the bit level of your JDK. So if you have a 64 bit Windows OS, you also need a 64 bit JDK to run 64 bit STS. On the other hand you can run STS 32 bit on your 64 bit Windows with a 32 bit JDK.

      HTH

      Christian

      Comment


      • #4
        re: STS & Eclipse 3.5

        Thanks Christian! You are right. In fact I was using a 64bit STS installation with a 32bit JVM on a 64bit Vista.

        But I would also like to add that the name of the 64bit STS installer suggests that it works for both 32 and 64 bits. The name of the installer:

        springsource-tool-suite-2.2.1.RELEASE-e3.5.1-win32-x86_64-installer

        It might be a good idea then to change the name.

        Cheers,
        Kamran

        Comment


        • #5
          Kamran,

          for STS 2.3.0 I expended the installer to detect the bit level of the JDK and make sure that the correct JDK is used with the correct STS version.

          Hope that this proves useful in the future.

          Christian

          Comment

          Working...
          X