Announcement Announcement Module
No announcement yet.
STS fails to start after installing extensions on OSX Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS fails to start after installing extensions on OSX

    I'm using:
    OS X 10.5.8 with a case sensitive file system
    Java(TM) SE Runtime Environment (build 1.6.0_15-b03-226)

    I have installed STS from:

    After installing STS I install the Groovy and Grails extensions and restart STS.
    STS fails to open and pops up a dialog referring me to a log file which contains:
    !SESSION Thu Nov 26 17:44:07 MST 2009 ------------------------------------------
    !ENTRY org.eclipse.equinox.launcher 4 0 2009-11-26 17:44:07.261
    !MESSAGE Exception launching the Eclipse Platform:
    java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
            at Method)
            at java.lang.ClassLoader.loadClass(
            at java.lang.ClassLoader.loadClass(
            at org.eclipse.equinox.launcher.Main.invokeFramework(
            at org.eclipse.equinox.launcher.Main.basicRun(
    The diff (diff -rq springsource springsource2) of the directories before installing the extensions and after is (springsource2 is the clean install):
    Only in springsource: .DS_Store
    Only in springsource/sts-2.2.1.RELEASE/ sts.ini
    Files springsource/sts-2.2.1.RELEASE/artifacts.xml and springsource2/sts-2.2.1.RELEASE/artifacts.xml differ
    Files springsource/sts-2.2.1.RELEASE/configuration/.settings/org.eclipse.ui.ide.prefs and springsource2/sts-2.2.1.RELEASE/configuration/.settings/org.eclipse.ui.ide.prefs differ
    Files springsource/sts-2.2.1.RELEASE/configuration/config.ini and springsource2/sts-2.2.1.RELEASE/configuration/config.ini differ
    Files springsource/sts-2.2.1.RELEASE/configuration/org.eclipse.core.runtime/.manager/.fileTable.7 and springsource2/sts-2.2.1.RELEASE/configuration/org.eclipse.core.runtime/.manager/.fileTable.7 differ
    Files springsource/sts-2.2.1.RELEASE/configuration/org.eclipse.core.runtime/.manager/.fileTable.8 and springsource2/sts-2.2.1.RELEASE/configuration/org.eclipse.core.runtime/.manager/.fileTable.8 differ
    Files springsource/sts-2.2.1.RELEASE/configuration/org.eclipse.core.runtime/.table.1 and springsource2/sts-2.2.1.RELEASE/configuration/org.eclipse.core.runtime/.table.1 differ
    Only in springsource2/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi: .bundledata.1
    Only in springsource/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi: .bundledata.2
    Only in springsource2/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi/.manager: .fileTable.4
    Files springsource/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi/.manager/.fileTable.5 and springsource2/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi/.manager/.fileTable.5 differ
    Only in springsource/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi/.manager: .fileTable.6
    Files springsource/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi/.state.1 and springsource2/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi/.state.1 differ
    Files springsource/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi/bundles/347/data/SCR and springsource2/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi/bundles/347/data/SCR differ
    Only in springsource/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi/bundles/365/data: -57300181
    Only in springsource2/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi/bundles/365/data: 1553553669
    Files springsource/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi/bundles/372/data/cache.timestamps and springsource2/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi/bundles/372/data/cache.timestamps differ
    Files springsource/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi/bundles/372/data/listener_1925729951/artifacts.xml and springsource2/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi/bundles/372/data/listener_1925729951/artifacts.xml differ
    Files springsource/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi/bundles/372/data/listener_1925729951/content.xml and springsource2/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi/bundles/372/data/listener_1925729951/content.xml differ
    Files springsource/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi/bundles/372/data/timestamps-897699915 and springsource2/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi/bundles/372/data/timestamps-897699915 differ
    Only in springsource/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi/bundles: 377
    Only in springsource/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi/bundles/381/data: -1187023094
    Only in springsource2/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi/bundles/381/data: -839923540
    Only in springsource/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi/bundles/427/1/.cp/org/eclipse/jface/dialogs/images: help.gif
    Only in springsource/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi/bundles: 543
    Only in springsource/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi/bundles/666/1/.cp/icons/full/dlcl16: progress_stop.gif
    Only in springsource/sts-2.2.1.RELEASE/configuration/org.eclipse.osgi/bundles/666/1/.cp/icons/full/elcl16: progress_stop.gif
    Files springsource/sts-2.2.1.RELEASE/configuration/org.eclipse.update/install.log and springsource2/sts-2.2.1.RELEASE/configuration/org.eclipse.update/install.log differ
    Files springsource/sts-2.2.1.RELEASE/configuration/org.eclipse.update/platform.xml and springsource2/sts-2.2.1.RELEASE/configuration/org.eclipse.update/platform.xml differ
    Only in springsource/sts-2.2.1.RELEASE/features: com.springsource.sts.grails_2.2.1.200910210131-RELEASE
    Only in springsource/sts-2.2.1.RELEASE/features: org.codehaus.groovy.eclipse.feature_2.0.0.xx-20091108-2000-e35
    Only in springsource/sts-2.2.1.RELEASE/features: org.codehaus.groovy.jdt.patch_2.0.0.xx-20091108-2000-e35
    Only in springsource/sts-2.2.1.RELEASE/features: org.codehaus.groovy16.feature_2.0.0.xx-20091108-2000-e35
    Only in springsource/sts-2.2.1.RELEASE/features: org.codehaus.groovy17.feature_2.0.0.xx-20091108-2000-e35
    Files springsource/sts-2.2.1.RELEASE/p2/org.eclipse.equinox.p2.engine/profileRegistry/com.springsource.sts.ide.profile/.data/.settings/org.eclipse.equinox.p2.artifact.repository.prefs and springsource2/sts-2.2.1.RELEASE/p2/org.eclipse.equinox.p2.engine/profileRegistry/com.springsource.sts.ide.profile/.data/.settings/org.eclipse.equinox.p2.artifact.repository.prefs differ
    Files springsource/sts-2.2.1.RELEASE/p2/org.eclipse.equinox.p2.engine/profileRegistry/com.springsource.sts.ide.profile/.data/.settings/org.eclipse.equinox.p2.metadata.repository.prefs and springsource2/sts-2.2.1.RELEASE/p2/org.eclipse.equinox.p2.engine/profileRegistry/com.springsource.sts.ide.profile/.data/.settings/org.eclipse.equinox.p2.metadata.repository.prefs differ
    Only in springsource/sts-2.2.1.RELEASE/p2/org.eclipse.equinox.p2.engine/profileRegistry/com.springsource.sts.ide.profile/.data/.settings: org.eclipse.equinox.p2.ui.sdk.prefs
    Files springsource/sts-2.2.1.RELEASE/p2/org.eclipse.equinox.p2.engine/profileRegistry/com.springsource.sts.ide.profile/.data/.settings/org.eclipse.equinox.p2.ui.sdk.scheduler.prefs and springsource2/sts-2.2.1.RELEASE/p2/org.eclipse.equinox.p2.engine/profileRegistry/com.springsource.sts.ide.profile/.data/.settings/org.eclipse.equinox.p2.ui.sdk.scheduler.prefs differ
    Only in springsource/sts-2.2.1.RELEASE/p2/org.eclipse.equinox.p2.engine/profileRegistry/com.springsource.sts.ide.profile: 1259282188939.profile.gz
    Only in springsource/sts-2.2.1.RELEASE/p2/org.eclipse.equinox.p2.engine/profileRegistry/com.springsource.sts.ide.profile: 1259282190952.profile.gz
    Only in springsource/sts-2.2.1.RELEASE/p2/org.eclipse.equinox.p2.engine/profileRegistry/com.springsource.sts.ide.profile: 1259282620776.profile.gz
    Only in springsource2/sts-2.2.1.RELEASE/p2/org.eclipse.equinox.p2.engine/profileRegistry/com.springsource.sts.ide.profile: 1259283337909.profile.gz
    Only in springsource2/sts-2.2.1.RELEASE/p2/org.eclipse.equinox.p2.engine/profileRegistry/com.springsource.sts.ide.profile: 1259283339243.profile.gz
    Only in springsource/sts-2.2.1.RELEASE/p2/org.eclipse.equinox.p2.repository/cache: compositeContent1095413072.jar
    Only in springsource/sts-2.2.1.RELEASE/p2/org.eclipse.equinox.p2.repository/cache: compositeContent1300562221.jar
    Only in springsource/sts-2.2.1.RELEASE/p2/org.eclipse.equinox.p2.repository/cache: content-1313268167.jar
    Only in springsource/sts-2.2.1.RELEASE/p2/org.eclipse.equinox.p2.repository/cache: content-1964146205.jar
    Only in springsource/sts-2.2.1.RELEASE/p2/org.eclipse.equinox.p2.repository/cache: content-445678946.jar
    Only in springsource/sts-2.2.1.RELEASE/p2/org.eclipse.equinox.p2.repository/cache: content-485972093.jar
    Only in springsource/sts-2.2.1.RELEASE/p2/org.eclipse.equinox.p2.repository/cache: content-836065428.jar
    Only in springsource/sts-2.2.1.RELEASE/p2/org.eclipse.equinox.p2.repository/cache: content-888347553.jar
    Only in springsource/sts-2.2.1.RELEASE/p2/org.eclipse.equinox.p2.repository/cache: content1048691197.jar
    Only in springsource/sts-2.2.1.RELEASE/p2/org.eclipse.equinox.p2.repository/cache: content816442617.jar
    I removed all the diffs for files in springsource/sts-2.2.1.RELEASE/plugins as it made the post to long.

    Any ideas on how to get it working?
    Last edited by aphahn; Nov 30th, 2009, 11:20 PM. Reason: Adding info

  • #2

    thanks for those many details. This is a recurring issue with STS 2.x and Mac OS. You are the first to report using the case sensitive filesystem, which might actually make the difference as I was never able to re-create this issue.

    Nevertheless the root cause to this will be fixed with STS 2.3.0. To work-around that now, please restore the missing "sts-2.2.1.RELEASE/" after you installed new plugins. For whatever reason file gets lost during the update. It is safe to just restore a copy from before the installation.

    Let me know if that helps.



    • #3

      I'm confused by the workaround you gave. sts-2.2.1.RELEASE/ gets created when the plugins are installed. In the clean install there is sts-2.2.1.RELEASE/ and after installing plugins both sts.ini and STS.ini are present in sts-2.2.1.RELEASE/ STS.ini remains unchanged after adding the plugins and sts.ini cotains:
      I have tried every combination of these files I can think of (including merging them) and still it won't start.

      Any ideas?
      I can help test fixes for this issue.



      • #4
        Hi Andy,

        yeah, sorry. On second read my reply wasn't very clear.

        Can you try to copy the original STS.ini to sts.ini and install some plugins. Does this solve the issue?



        • #5
          Thanks Christian,
          Moving sts-2.2.1.RELEASE/ to sts-2.2.1.RELEASE/ before installing any plugins did the trick.

          Thanks again,



          • #6
            Interesting, I just had this issue on OSX 10.6.8 using STS 2.7.2.RELEASE. I ran the installer, which completed and lauched STS with no trouble.

            After applying the available updates, I tried to restart STS and got this error:

            You can't open the application because it may be damaged or incomplete.

            I reinstalled STS in another location and renamed sts-2.7.2.RELEASE/ from STS.ini to sts.ini. I then applied the available updates and restarted without error.

            Thanks Christian and Andy!



            • #7
              Slightly different solution?

              Originally posted by ross.jourdain View Post
              Interesting, I just had this issue on OSX 10.6.8 using STS 2.7.2.RELEASE. I ran the installer, which completed and lauched STS with no trouble.

              After applying the available updates, I tried to restart STS and got this error
              I have the same issue, maybe I should try the ini fix, but I also found that running the STS app in the contents/macos... folder works for me, it starts and runs.


              • #8
                Christian Dupuis, you said this problem should be fixed for version 2.3 but I have installed the 2.9.1 version and still exists the same issue. Thanks anyway.


                • #9

                  Does the described workaround works for you as well? Just asking...
                  And are you on a case-sensitive file system as well?



                  • #10
                    Originally posted by Martin Lippert View Post

                    Does the described workaround works for you as well? Just asking...
                    And are you on a case-sensitive file system as well?

                    MBP OS X 10.7.4

                    I've just installed the Spring Source Toolsuite v sts-2.9.2.RELEASE and each time I install to /applications I encountered the above error...well, in that the application would present the:
                    'cannot open the application STS because it may be damaged or incomplete'
                    message after the first STS boot.

                    I installed to ~/ [user folder] instead and the STS application would boot fine on numerous occasions.

                    copying STS.ini to the /applications/STS folder did not resolve the issue for me; however, I did notice that the application had rights/privileges for user [read/write], staff and everyone [read only] but no admin rights which might be the sticking point here for some installations?

                    just a thought. I would test this with modified rights to a /applications installation and repost but just at this moment my poker tournaments have gone mental - my apologies for a half-hearted response.



                    • #11
                      Hey nomad!

                      Thanks for the additional details. I usually install and run STS on my OSX machine with the admin rights user, so it is easily possible that I never came across those permission problems you are seeing. I will go ahead and try that as well. In the meantime, whenever you find some more details, let us know.



                      • #12
                        Using: STS-2.9.2.RELEASE on Lion

                        Installed STS to ~/springsource as a user with admin rights (and I only use the tool suite as the same user) with some success for a while. I needed to install the XCode command line tools for mac ports and after the next restart "boom", STS cannot be started because it is damaged or incomplete.

                        Permissioning looked aright @ 755 throughout. I also have not tried the .ini suggestion because I am unsure of where I can find a valid copy to replace it with. Here is the current content of the sts.ini file:

                        ../../../plugins/org.eclipse.equinox.launcher.cocoa.macosx_1.1.101. v20120109-1504

                        Another interesting fact: if I run the STS symlink directly it runs fine, but clicking on the application pops up the message above.

                        Hope this helps!


                        • #13

                          It is strange that the installation of the Xcode tools from Apple causes this kind of problem. The content of the sts.ini file looks ok. What happens if you rename sts.ini to STS.ini? And what happens with a fresh installation of STS? Does that work? (just trying to find out where the problem might be)



                          • #14
                            I noticed this problem on a clean install of STS (springsource-tool-suite-2.9.2.RELEASE-e3.7.2-macosx-cocoa-x86_64-installer.dmg) on OSX Lion 10.7.4.

                            I installed into /Users/<username>/springsource/

                            I'm unable to launch STS using the app icon but using the STS symlink directly in the terminal works fine.

                            Edit: I fixed the issue by running chmod on STS.ini in /Users/<username>/springsource/sts-2.9.2.RELEASE/

                            chmod 664 STS.ini (by default STS.ini has 644).
                            Last edited by mdorey; Jul 17th, 2012, 07:25 PM.


                            • #15
                              Maybe I don't know what I'm doing from the command line but, I just went into the .../ dir and typed "chmod 664 STS.ini" - is that right?

                              If so, it didn't work.

                              Anyone have any other suggestions?