Announcement Announcement Module
Collapse
No announcement yet.
Spring Template Dowload behind a Proxy Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring Template Dowload behind a Proxy

    version: sts-2.2.1.RELEASE

    During creation of a new Spring Template Project, a download is required but it fails.

    I'm behind a proxy and use this trick to allow eclipse to pass through a NTLM authentication (http://le-moulin-de-verre.com/fieldnotes/?p=103), may be Template Wizard ignore it and use the default Apache httpclient ...

    Event Details:
    ----------------------------------------
    eclipse.buildId=M20090917-0800
    java.version=1.6.0
    java.vendor=Sun Microsystems Inc.
    BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=fr_FR
    Framework arguments: -product com.springsource.sts.ide
    Command-line arguments: -os win32 -ws win32 -arch x86 -product com.springsource.sts.ide


    Error
    Mon Nov 30 17:22:41 CET 2009
    Unexpected server response: '407'
    -------------------------------------------

    Any ideas ?
    Last edited by Saloucious; Nov 30th, 2009, 10:28 AM.

  • #2
    Re: Spring Template Dowload behind a Proxy

    Hi Saloucious,

    I had the same problem and I solved that way:

    I set -Dorg.eclipse.ecf.provider.filetransfer.excludeCont ributors, -Dhttp.proxyPort, -Dhttp.proxyHost, -Dhttp.nonProxyHosts keys in STS.ini file as I have described below

    -Dorg.eclipse.ecf.provider.filetransfer.excludeCont ributors=org.eclipse.ecf.provider.filetransfer.htt pclient
    -Dhttp.proxyPort=[your_proxy_port]
    -Dhttp.proxyHost=[your_proxy_host]
    -Dhttp.nonProxyHosts=localhost|127.0.0.1
    In Windows --> Preferences --> Network Connections I set:

    Active Provider: Manual

    (checked) Schema: HTTP Host: [your_proxy_host] Port: [your_proxy_port] Provider: Manual Auth: true User: [your_proxy_user] Password: [your_proxy_passwd]
    (checked) Schema: HTTPS Host: [your_proxy_host] Port: [your_proxy_port] Provider: Manual Auth: false User: void Password: void
    (checked) Schema: SOCKS Host: [your_proxy_host] Port: [your_proxy_port] Provider: Manual Auth: false User: void Password: void

    Proxy bypass

    (checked) Host: localhost Provider: Manual
    (checked) Host: 127.0.0.1 Provider: Manual

    I hope you can help
    Regards

    Comment

    Working...
    X