Announcement Announcement Module
Collapse
No announcement yet.
STS Extensions x Update Manager Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS Extensions x Update Manager

    Are "STS Extensions" installed using the Extensions tab on the STS Dashboard view visible (and uninstallable) from Update Manager?

    Is the "STS Extensions" simply a shortcut for the Update Manager?

    I'm asking because I see two "Grails" entries under "Languages and Frameworks" that I can't figure out how to uninstall, and I think they're preventing me from installing the stable (?) Groovy support plugin.

    http://img684.imageshack.us/img684/3...9114609.th.png

  • #2
    Hi,

    Originally posted by dserodio View Post
    Are "STS Extensions" installed using the Extensions tab on the STS Dashboard view visible (and uninstallable) from Update Manager?
    Yes, they are un-installable using the usual Eclipse mechanisms.

    Originally posted by dserodio View Post
    Is the "STS Extensions" simply a shortcut for the Update Manager?
    Yes, the Extension install is driving the Eclipse Update Manager/P2 under the cover.

    Originally posted by dserodio View Post
    I'm asking because I see two "Grails" entries under "Languages and Frameworks" that I can't figure out how to uninstall, and I think they're preventing me from installing the stable (?) Groovy support plugin.
    Those two Grails entries are the Grails runtime downloads 1.1.1 and 1.2.0.M4. Those should not prevent you from installing the Groovy support plugin.

    What is the error message you are seeing?

    Christian

    Comment


    • #3
      Thanks for the prompt reply. The error I'm getting is:

      Code:
      Cannot complete the install because of a conflicting dependency.
        Software being installed: Groovy-Eclipse Feature 2.0.0.xx-20091108-2000-e35 (org.codehaus.groovy.eclipse.feature.feature.group 2.0.0.xx-20091108-2000-e35)
        Software currently installed: Maven Integration for WTP (Optional) 0.9.9.200911171109 (org.maven.ide.eclipse.wtp.feature.feature.group 0.9.9.200911171109)
        Only one of the following can be installed at once: 
          JDT Core patch for Groovy-Eclipse plugin 2.0.0.xx-20091108-2000-e35 (org.codehaus.groovy.jdt.patch.feature.jar 2.0.0.xx-20091108-2000-e35)
          JDT Core patch for Groovy-Eclipse plugin 2.0.0.xx-20091001-1400-e35 (org.codehaus.groovy.jdt.patch.feature.jar 2.0.0.xx-20091001-1400-e35)
        Only one of the following can be installed at once: 
          Java Development Tools Core 3.5.1.xx-20091001-1400-e35 (org.eclipse.jdt.core 3.5.1.xx-20091001-1400-e35)
          Java Development Tools Core 3.5.1.v_972_R35x (org.eclipse.jdt.core 3.5.1.v_972_R35x)
          Java Development Tools Core 3.5.1.xx-20091108-2000-e35 (org.eclipse.jdt.core 3.5.1.xx-20091108-2000-e35)
          Java Development Tools Core 3.5.0.v_963 (org.eclipse.jdt.core 3.5.0.v_963)
        Cannot satisfy dependency:
          From: Groovy-Eclipse Feature 2.0.0.xx-20091108-2000-e35 (org.codehaus.groovy.eclipse.feature.feature.group 2.0.0.xx-20091108-2000-e35)
          To: org.codehaus.groovy.jdt.patch.feature.group [2.0.0.xx-20091108-2000-e35]
        Cannot satisfy dependency:
          From: JDT Core patch for Groovy-Eclipse plugin 2.0.0.xx-20091001-1400-e35 (org.codehaus.groovy.jdt.patch.feature.group 2.0.0.xx-20091001-1400-e35)
          To: org.codehaus.groovy.jdt.patch.feature.jar [2.0.0.xx-20091001-1400-e35]
        Cannot satisfy dependency:
          From: JDT Core patch for Groovy-Eclipse plugin 2.0.0.xx-20091108-2000-e35 (org.codehaus.groovy.jdt.patch.feature.group 2.0.0.xx-20091108-2000-e35)
          To: org.codehaus.groovy.jdt.patch.feature.jar [2.0.0.xx-20091108-2000-e35]
        Cannot satisfy dependency:
          From: Eclipse Java Development Tools 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1 (org.eclipse.jdt.feature.group 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1)
          To: org.eclipse.jdt.core [3.5.0.v_963]
        Cannot satisfy dependency:
          From: Eclipse Java Development Tools 3.5.1.r351_v20090810-0600-7r88FEoFI0WTo6Az-1qFRHm37ChJ (org.eclipse.jdt.feature.group 3.5.1.r351_v20090810-0600-7r88FEoFI0WTo6Az-1qFRHm37ChJ)
          To: org.eclipse.jdt.core [3.5.1.v_972_R35x]
        Cannot satisfy dependency:
          From: Maven Integration for WTP (Optional) 0.9.9.200911171109 (org.maven.ide.eclipse.wtp.feature.feature.group 0.9.9.200911171109)
          To: org.eclipse.jdt.feature.group 3.2.0
        Cannot satisfy dependency:
          From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.0.0.xx-20091108-2000-e35 Eclipse Java Development Tools 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1 (org.eclipse.jdt.feature.group 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1)
          To: org.eclipse.jdt.core [3.5.1.xx-20091108-2000-e35]
        Cannot satisfy dependency:
          From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.0.0.xx-20091108-2000-e35 Eclipse Java Development Tools 3.5.1.r351_v20090810-0600-7r88FEoFI0WTo6Az-1qFRHm37ChJ (org.eclipse.jdt.feature.group 3.5.1.r351_v20090810-0600-7r88FEoFI0WTo6Az-1qFRHm37ChJ)
          To: org.eclipse.jdt.core [3.5.1.xx-20091108-2000-e35]

      Comment


      • #4
        dserodio,

        from the error report you posted I'm not quite sure what you installed before your attempt to install the Groovy tools.

        Can you please provide some details about your installation history? I assume that you are not using the STS 2.2.1 package download?

        Christian

        Comment


        • #5
          Over a base install of "Eclipse IDE for Java and Report Developers" 3.5.1, I installed STS 2.1.0, m2eclipse, JBoss Tools (just the Hibernate support), Subclipse, PDT and a few other "minor" plugins.

          Is there a "human-readable" export format of the Installation History I could post here?

          http://img413.imageshack.us/img413/2...9143305.th.png

          Comment


          • #6
            Hi dserodio,

            Have you installed an earlier version of Groovy-Eclipse? If so, I'd recommend uninstalling that (and all of your Grails-Eclipse tooling) before trying to upgrade.

            Also, uncheck "Contact all update sites" from inside the update manager before trying to install.

            A combination of these two often fixes a problematic install.

            Comment


            • #7
              Thank you, I had a "JDT core patch" leftover from a previous Groovy-Eclipse install.
              After uninstalling it and unchecking "Contact all update sites", I was able to install the newest Groovy and Grails support.

              Comment

              Working...
              X