Announcement Announcement Module
Collapse
No announcement yet.
STS VM arguments not working Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS VM arguments not working

    Hello,
    when trying to add more than one argument in the VM arguments of Run Configurations (for exemple : -Dgrails.env=dev[space]-Xms256m, i get the following message when running grails :
    Environment set to dev -Xms256m
    It seems like arguments are not parsed correctly in System.getProperty().

    Can anybody help ?

    Thanks
    David

    Configuration
    STS 2.2.1
    JDK 1.6 r17
    Grails 1.1.1

  • #2
    David,

    I've fixed this bug in the nightly build of STS. You can get this fix tomorrow from the snapshot update site at http://www.springsource.com/snapshot/e3.5.

    Let me know if that fixes your issue. Sorry for the inconvenience.

    Christian

    Comment


    • #3
      Everything 's ok

      Thanks a lot. It perfectly works now !

      Comment


      • #4
        Hi,

        Now I can put 2 arguments in VM arguments box, but can't do more than 3 arguments like: -Xms512m -Xmx768m -XX:MaxPermSize=256m

        Invalid maximum heap size: -Xmx768m -XX:MaxPermSize=256m

        Please recheck grails run configuration

        My env.

        STS 2.3.0
        grails 1.2.0 rc2

        Comment


        • #5
          Hi,

          I just committed another fix that will make sure the VM parameters work for more then two parameters.

          Sorry for this. Can you try tomorrow's nightly snapshot?

          Christian

          Comment


          • #6
            Thanks so much !! I can't wait to try out grails support on STS !
            _________________________
            Devis comparatif mutuelle sante |
            Comparateur mutuelles sante |
            Comparer comparatif mutuel
            Last edited by hoppetspat; Dec 28th, 2009, 07:54 PM.

            Comment

            Working...
            X