Announcement Announcement Module
Collapse
No announcement yet.
STS 3.4 fails on Mac OSX Mavericks Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS 3.4 fails on Mac OSX Mavericks

    Hello,

    I've been using STS 3.4 on my MacBook Pro for nearly a year. I love it!

    Unfortunately, when I upgraded to OSX Mavericks (v10.9) STS no longer launches. I get the following message: "The JVM shared library "/Library/Java/JavaVirtualMachines/openjdk-1.7-x86_64"
    does not contain the JNI_CreateJavaVM symbol."

    I modified the STS.ini file to point to all of the JDKs that I have installed but none of them seem to work (same error message).

    I have googled this problem and searched the Spring fora but have not found any known issues. Has anyone else had this problem? How did you resolve it?

    Thanks,
    Bryan

  • #2
    Never mind. I just reinstalled STS and it is working just fine.

    Comment


    • #3
      Hey Bryan,

      glad to hear that you solved the issue and thanks for sharing your solution here. Much appreciated!

      Cheers,
      -Martin

      Comment


      • #4
        In case anybody else runs into issues on Mavericks and finds this thread, I think it's a good idea to reinstall your JDK after the update. I'm not sure to what degree Mavericks modifies the system directories, but Eclipse was complaining about some missing class path libraries following the update. Reinstalling the JDK helped.

        Comment


        • #5
          I am trying to install STS-3.4 on Mavericks;

          A popup says: "To open Installer - Spring Tool Suite 3.4.0.RELEASE, you need a Java SE 6 runtime. Would you like to install one now?"

          This, even though I have already installed jdk-7u45 [and jre-7u45 as well]
          (which is not specifically Java SE 6, but is the only recommended/supported JDK for macos])

          Clicking "OK", the installer spins "finding software" and then complains: "The software is currently unavailable. To install a Java SE 6 runtime later, open Installer - Spring Tool Suite 3.4.0.RELEASE again."

          How do I get the installer to run?

          Code:
          :~>java -version
          java version "1.7.0_45"
          Java(TM) SE Runtime Environment (build 1.7.0_45-b18)
          Java HotSpot(TM) 64-Bit Server VM (build 24.45-b08, mixed mode)
          Last edited by Jack Punt; Oct 28th, 2013, 05:44 PM.

          Comment


          • #6
            Hey!

            The STS installer requires an Apple JDK 6 to run, it cannot run with a JDK 7. This is due to an incompatibility between JDK6 and JDK7 on Mac and they way those JDKs are being launched by a small native component. There doesn't seem to be a way to support both versions on a Mac at the same time using this native launching component. But this affects the installer only. STS itself runs fine with JDK6 and JDK7 installed on your Mac, even if you don't have a JDK6.

            The workaround for this is to download tar.gz-Version of STS, extract that, and go from there. That way you get STS running on your Mac without a JDK6.

            HTH,
            Martin

            Comment


            • Jack Punt
              Jack Punt commented
              Editing a comment
              that works, thank you!

          • #7
            Glad to hear that this work for you. Thanks for letting us know!

            Cheers,
            -Martin

            Comment

            Working...
            X