Announcement Announcement Module
Collapse
No announcement yet.
Error installing pluging in STS 2.1.0 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error installing pluging in STS 2.1.0

    I've just downloaded STS 2.1.0 windows zip distro (without Groovy).
    Now I'm trying to install Subclipse and Google plugin but I keep getting:

    An error occurred while collecting items to be installed
    session context wasprofile=com.springsource.sts.ide, phase=org.eclipse.equinox.internal.provisional.p2. engine.phases.Collect, operand=, action=).
    No repository found containing: osgi.bundle,com.ibm.icu,4.0.1.v20090822
    No repository found containing: osgi.bundle,org.eclipse.equinox.p2.touchpoint.ecli pse,1.0.101.R35x_20090820-1821
    No repository found containing: osgi.bundle,org.eclipse.equinox.p2.ui,1.0.101.R35x _v20090819
    No repository found containing: osgi.bundle,org.eclipse.jdt.apt.pluggable.core,1.0 .201.R35x_v20090818-0225
    No repository found containing: osgi.bundle,org.eclipse.jdt.core,3.5.1.v_972_R35x
    No repository found containing: osgi.bundle,org.eclipse.jdt.doc.user,3.5.1.r351_v2 0090821-0800
    No repository found containing: osgi.bundle,org.eclipse.jdt.ui,3.5.1.r351_v2009082 1-0800
    No repository found containing: osgi.bundle,org.eclipse.pde.doc.user,3.5.0.v200908 18
    No repository found containing: osgi.bundle,org.eclipse.platform.doc.user,3.5.1.r3 51_v20090821-0800
    No repository found containing: osgi.bundle,org.eclipse.ui.forms,3.4.1.v20090714_3 5x
    No repository found containing: osgi.bundle,org.eclipse.ui.intro,3.3.1.v20090805_3 5x
    No repository found containing: binary,org.eclipse.rcp.configuration_root.win32.wi n32.x86,1.0.0.M20090917-0800

    What's wrong?

  • #2
    Seems a Eclipse repository problem: http://www.eclipse.org/forums/index....ba3#msg_488456

    Comment


    • #3
      Marcel,

      I can't really explain what is going on but I suspect some changes on the Galileo update site are the cause of this issue.

      I could reproduce this error; once I disabled all other update sites before installing Subclipse I could successfully finish the installation.

      Can you try this?

      HTH

      Christian

      Comment


      • #4
        Well, maybe I should check for replies first; just saw your follow-up Marcel.

        Christian

        Comment


        • #5
          You're brilliant!
          Disabling other Eclipse update sites did the trick.

          After 2 evenings (of frustration) finally got my Eclipse env set up.

          Comment

          Working...
          X