Announcement Announcement Module
Collapse
No announcement yet.
Eclipse MDT and sts-2.1.0.SR01 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Eclipse MDT and sts-2.1.0.SR01

    Cannot install Eclipse MDT into my sts. I enabled the galileo update site and selected "modeling". Install proceeded normally, no errors, plugins appear in my plugins list...but there is no "modeling" menu option under file->new->other.

    A similar problem (with a third-party modeling plugin) was noted here:

    http://forum.springsource.org/showthread.php?t=77370

    Specifically I am trying to install specifically is the UML2 Toolkit mentioned here:

    http://www.vogella.de/articles/UML/article.html
    http://www.eclipse.org/modeling/mdt/...ject=uml2tools

    (It installs just fine into a plain version of Eclipse.)

    Are there any known workarounds for this? Is there a general issue with installing additional plugins into STS that STS doesn't activate them?

  • #2
    Hi,

    I just installed the "UML2 Tools SDK" feature from the Galileo -> Modeling update site.

    You are right, after that there is no Modeling section available in File -> New -> Other. But by following the linked article I see a "UML 2.1 Diagrams" section in File -> New -> Other. This allows me to create Class and other UML diagrams just fine.

    Is that what you are looking for? Or is that "UML 2.1 Diagrams" menu not there for you?

    Christian

    Comment


    • #3
      Resolved with fresh STS install

      Christian,

      Sorry, I mis-stated that in my post. I was looking for "UML 2.1 Diagrams' and it was not there despite what looked like a successful install of the plugin.

      However, I did ultimately resolve this by re-installing STS into a new location. (I promise I tried this BEFORE posting here, but I must have polluted the install somehow and it didn't work.)

      Sorry for taking up your time with this, and thanks for your reply. The following ultimately worked for me:
      1) Install a fresh STS into a NEW location using installer (w/o groovy in my case)

      2) Open STS (make sure to use the shortcut pointing to the version you just installed!)

      3) Before doing anything else, select "galileo" from the update site, select "Modeling->UML2 Toolkit" and install

      4) Restart STS

      5) To verify that UML2 Toolkit is installed: Select "File->New->Other" and look for the menu item "UML 2.1 Diagrams"

      Comment

      Working...
      X