Announcement Announcement Module
Collapse
No announcement yet.
Spring IDE (Eclipse) errors in template.mf when using maven and bundlor Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring IDE (Eclipse) errors in template.mf when using maven and bundlor

    I using Eclipse 3.5 with the Spring IDE as described in this blog post. I am using maven with the bundlor plugin. I specify the Bundle-SymbolicName, Bundle-Version, and Bundle-Name manifest headers in the bundlor configuration within the pom.xml. This leaves only a couple of static headers in the template.mf.

    <plugin>
    <groupId>com.springsource.bundlor</groupId>
    <artifactId>com.springsource.bundlor.maven</artifactId>
    <version>1.0.0.M2</version>
    <configuration>
    <manifestHeaders>
    <![CDATA[Bundle-SymbolicName: ${pom.groupId}.${pom.artifactId}
    Bundle-Name: ${pom.artifactId}
    Bundle-Description: ${pom.description}
    Bundle-Version: ${pom.version}
    ...
    </manifestHeaders>
    </configurations>
    </plugin>

    The problem is that I am getting errors from the Spring IDE (Eclipse) in the template.mf claiming that I don't have the Bundle-SymbolicName, Bundle-Name, and Bundle-Version specified even though they are defined in the pom. However, there is no error. My manifest.mf generates just fine when I do a maven build. How do I turn this false error off?

  • #2
    Hi,

    in your special setup the Bundle-SymbolicName, etc headers are not detected by STS. Could you please raise a JIRA against STS so that it can deal with that setup in the future.

    As a workaround you can always disable the validation from the Spring preferences (expand the two Manifest validators and deselect the rules you don't want).

    HTH

    Christian

    Comment


    • #3
      I fixed this in trunk. STS will now only validate the structure of a template.mf resource and not the existence of Bundle-Name, etc. headers which will be validated on the Manifest itself.

      Christian

      Comment


      • #4
        Thank you Christian. I will use the work around you suggested. Since you already made a change in the trunk, I will not open a JIRA.

        Thank you for your quick response.

        Comment

        Working...
        X