Announcement Announcement Module
Collapse
No announcement yet.
Problems downloading SpringIDE (specifically OSGI packages) Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems downloading SpringIDE (specifically OSGI packages)

    An error occurred while collecting items to be installed
    No repository found containing: org.aspectj.ajde/osgi.bundle/1.6.4.20090304172355
    No repository found containing: org.aspectj.runtime/osgi.bundle/1.6.4.20090304172355
    No repository found containing: org.aspectj.weaver/osgi.bundle/1.6.4.20090304172355
    No repository found containing: org.eclipse.ajdt.core/osgi.bundle/1.6.4.20090313172428
    No repository found containing: org.eclipse.contribution.weaving.jdt/osgi.bundle/1.6.4.20090313172428


    I get that error when attempting to install SpringIDE from several different update sites.

    http://www.springsource.org/update/e3.4
    http://dist.springframework.org/release/IDE
    http://springide.org/updatesite

    I have tried all three of those locations and receive the error above for all 3, I attempt to only download the single SpringIDE core update and even that gives these errors.

    Any ideas? Is there an issue with the site or does this sound like it could be an issue on my side?

    Thanks.
    This worked for me before (I had an older SpringIDE installed previously) and I don't believe I've changed anything too significant.

  • #2
    I know that doing these updates in a fresh eclipse install works just fine.

    Any ideas on how I can fix my existing installation? Are there any caches or anything else I can clear?

    Comment


    • #3
      I had same errors. But while I was installing Eclipse IAM. Uninstalling Spring IDE before installing Eclipse IAM helped me to install Eclipse IAM without errors.

      Havent tried to reinstall Spring IDE yet.
      Last edited by logij; Jun 10th, 2009, 08:23 AM.

      Comment


      • #4
        try to remove the update site and put it back in again. it worked for me.

        Comment


        • #5
          no repository found at http springide.org updatesite

          "no repository found at http springide.org updatesite" error in eclipse when I am trying to update my eclipse .. I am currently using eclipse 3.4.2 version .. Please help me

          Comment


          • #6
            Hi!

            The update sites at springide.org are no longer available. I would recommend to remove that update site from your list of available update sites in Eclipse.

            The new update sites for Spring IDE provide support for Eclipse 3.6 and 3.7, so I don't know whether you will be able to install and/or run that on Eclipse 3.4, so I would recommend to update your base Eclipse installation to something newer, maybe the latest Eclipse Indigo release (aka 3.7) and install Spring IDE from the Eclipse Marketplace into that Eclipse installation. That is definitely the easiest way to get just Spring IDE.

            The other option is to download the complete SpringSource Tool Suite, which includes Spring IDE, Eclipse Indigo 3.7, and some pre-installed addons, its definitely the easiest way to setup a new environment. The downloads are here: http://www.springsource.com/developer/sts.

            HTH,
            Martin

            Comment


            • #7
              RE :Problems downloading SpringIDE (specifically OSGI packages)

              Hi Martin,
              Thanks for your reply... I will upgrade my eclipse and try ...

              Comment

              Working...
              X