Announcement Announcement Module
Collapse
No announcement yet.
STS 2.0.0 won't install M2E plugin Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS 2.0.0 won't install M2E plugin

    I've downloaded and installed STS 2.0.0 (enterprise license, plat support) in order to do some DM Server app development.

    I'm trying to install the latest release of the M2E plugin (currently 0.9.7.200902090947). Available from Sonatype's release update site:

    http://m2eclipse.sonatype.org/update/

    After adding this update site in STS, I do Help->Software Updates, select the Available Software tab, select everything under the "Maven Integration for Eclipse Update Site", and then select Install. This churns for a moment, and then fails with the following detail:

    Cannot complete the request. See the details.
    Cannot find a solution satisfying the following requirements org.eclipse.swt [3.4.0.v3448f].


    If I go under Help->About SpringSource Tool Suite, Plug-in Details, I can see an entry for org.eclipse.swt, with a version of 3.4.2.v3452b. I've tried updating with the dev version of m2e with pretty much the same results.

    What's the deal here, is STS essentially too new for the current build of M2E? How can I get this working? I cannot live without m2e.

    -Scott

  • #2
    Scott,

    I can reproduce the problem with STS 2.0 and the m2eclipse that you provided. If I select everything from the m2eclipse update site I get a very similar error report from p2 update manager.

    What solved the problem for me was to de-select the "Maven SCM handler for Subclipse (optional)" or to install Subclipse from http://subclipse.tigris.org/update_1.6.x beforehand.

    Let me know if that works for you.

    Christian

    Comment


    • #3
      Scott,

      I have a related question:

      I cannot live without m2e.
      I'm interested on the community view on both Maven Eclipse integrations.

      Have you evaluated Q4E as well? Why did you go with m2eclipse vs. Q4E.

      Christian

      Comment


      • #4
        Thanks Christian, this worked for me as well! We currently use a different SCM than subversion so I didn't need that part of the plugin anyway.

        We've been using m2e for about 6 months now, after I was tasked with introducing automated builds within our group. At that point, we adopted maven as the build tool and Hudson for our CI server. We've seen great improvements in build quality and general productivity.

        Right now, working on dmServer code is more frustrating since I have to update the manifest and the POM for every dependency. I've read Rob's blog entry on the upcoming POM->manifest and manifest->POM integrations, and I'm really looking forward to those. I'm not sure which I'll use, but the nexus index search makes it really easy to find and add dependencies. If it's any more difficult then this, then I'll probably go POM->manifest.

        I'm really interested in knowing what interim solutions people are using until this manifest/POM disconnect is solved. Right now, I am using the maven-war-plugin to specify my manifest entries. So after I search and add the dependency for maven (easy), I then have to go to the springsource repository website, find the corresponding bundle, copy the import line from there, and put it in the maven-war-plugin section in the POM (tedious).

        The critical point for us is that our projects have to build/run unit tests in Hudson. If it doesn't do that, then we're taking a huge step backwards. Maven makes this trivial right now.

        Back to M2E.. it has matured a lot during the past 6 months, and is really working well for us now.

        I tried Q4E 0.8.1 over the past few days, when I couldn't get M2E to work in STS. I'm not sure if I had the wrong version or what, but my experience was painful. For example, I needed the maven xjc plugin to generate JAXB classes. I tried to copy/paste pluginRepositories section into my POM source, and Eclipse would throw a NPE. If I tried to manually type in the pluginRepositories section, Eclipse would hard lock! If I added the section in a text editor, then opened the file in Eclipse, the pluginRepositories section would be gone, and half my repository entries would be gone as well! Modified and saved just by me opening the file. At that point I gave up on Q4E and just went to running mvn command-line.

        Some features of M2E that I really like that I did not see in the short time I used Q4E:

        - Ability to search for artifacts via. a nexus index, which includes our internal repo. I'm guessing this feature is there and I just missed it.
        - The dependency hierarchy / dependency graph views, which are great for seeing all the transitive dependencies at a glance.
        - Being able to exclude an artifact from said views (I want log4j but not the jms piece for example).

        Thanks again for your help.

        -Scott

        Comment


        • #5
          From my standpoint m2Eclipse works better with Nexus (IMHO leading m2 proxy), WTP, AJDT and it just feels better. It is rough at the edges but it seemed to me that sonatype is doing a lot more besides producing eclipse integration plugin.

          Another reason: last year m2ecelipse had shorter release cycles and it was getting better with each iteration.

          Unfortunately sonatype slowed down with m2eclipse development (perhaps has something to do with Eugene Kuleshov searching for a new job?).

          Comment

          Working...
          X