Announcement Announcement Module
Collapse
No announcement yet.
Unable to Install Spring IDE - Conflict with MyEclipse Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to Install Spring IDE - Conflict with MyEclipse

    I am in the process of upgrading my Eclipse installation to version 3.4.2.
    Amongst other plugins, I use MyEclipse (version 7.1.0.zmyeclipse7102009030516).

    When I try and install the Spring IDE from the update site, I get the following errors, which seem to show a conflict with MyEclipse, and am unable to install the IDE:

    Code:
    Cannot complete the request.  See the details.
    Cannot find a solution where both "org.springframework.ide.eclipse.core [2.2.0.zmyeclipse7102009030516]" and "org.springframework.ide.eclipse.core [2.2.2.RELEASE]" are satisfied.
    Cannot find a solution where both "org.springframework.ide.eclipse.beans.ui.search [2.2.0.zmyeclipse7102009030516]" and "org.springframework.ide.eclipse.beans.ui.search [2.2.2.RELEASE]" are satisfied.
    Cannot find a solution where both "org.springframework.ide.eclipse.beans.core [2.2.0.zmyeclipse7102009030516]" and "org.springframework.ide.eclipse.beans.core [2.2.2.RELEASE]" are satisfied.
    Cannot find a solution where both "org.springframework.ide.eclipse.beans.ui [2.2.0.zmyeclipse7102009030516]" and "org.springframework.ide.eclipse.beans.ui [2.2.2.RELEASE]" are satisfied.
    Cannot find a solution where both "org.springframework.ide.eclipse.beans.ui.refactoring [2.2.0.zmyeclipse7102009030516]" and "org.springframework.ide.eclipse.beans.ui.refactoring [2.2.2.RELEASE]" are satisfied.
    Cannot find a solution where both "org.springframework.ide.eclipse.doc [2.1.0.zmyeclipse7102009030516]" and "org.springframework.ide.eclipse.doc [2.2.2.RELEASE]" are satisfied.
    Cannot find a solution where both "org.springframework.ide.eclipse.ui [2.2.0.zmyeclipse7102009030516]" and "org.springframework.ide.eclipse.ui [2.2.2.RELEASE]" are satisfied.
    Cannot find a solution where both "org.springframework.ide.eclipse.beans.ui.graph [2.2.0.zmyeclipse7102009030516]" and "org.springframework.ide.eclipse.beans.ui.graph [2.2.2.RELEASE]" are satisfied.
    Cannot find a solution where both "org.springframework.ide.eclipse.beans.ui.editor [2.2.0.zmyeclipse7102009030516]" and "org.springframework.ide.eclipse.beans.ui.editor [2.2.2.RELEASE]" are satisfied.
    Cannot find a solution where both "org.eclipse.wst.sse.ui [1.1.3.zmyeclipse7102009030516]" and "org.eclipse.wst.sse.ui [1.1.4.v200901202345]" are satisfied.
    Cannot find a solution where both "org.springframework.ide.eclipse.beans.ui.refactoring [2.2.0.zmyeclipse7102009030516]" and "org.springframework.ide.eclipse.beans.ui.refactoring [2.2.2.RELEASE]" are satisfied.
    Cannot find a solution where both "org.springframework.ide.eclipse.core [2.2.0.zmyeclipse7102009030516]" and "org.springframework.ide.eclipse.core [2.2.2.RELEASE]" are satisfied.
    Is there any way round this?

    The above errors listing has been shortened to fit within the posting limits.

  • #2
    Hi,

    The problem here is directly related to the way that Genuitec, the company behind MyEclipse, uses SpringIDE (and other open source technology) in their product. Instead of using the SpringIDE as is, Genuitec modifies the project slightly before bundling it into their product which is the cause of the error reports that you are receiving. Basically, they make it very difficult to have installed MyEclipse and any version of SpringIDE other than the one they distribute.

    Since you are a paying MyEclipse customer, I would strongly encourage you to raise a support ticket with them to resolve this problem. This is a known issue and they have made promises to possibly resolve this in version 7.5.

    Adam FitzGerald
    SpringSource

    Comment


    • #3
      Thanks Adam - I've contacted MyEclipse. I'l let you know if I make any progress.

      Comment

      Working...
      X