Announcement Announcement Module
Collapse
No announcement yet.
SpringIDE and Eclipse 3.5 Galileo? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • SpringIDE and Eclipse 3.5 Galileo?

    Hello,

    yesterday I installed the Eclipse Galileo 3.5M5. The I added the SpringIDE Updatesite and wanted to install the SpringIDE Core 2.2.1 (and nothing else).

    Unfortunately Eclipse said:

    "Cannot find a solution satisfying the following requirements org.eclipse.jdt.apt.core [3.3.101.R34x_v20080902-1220]."

    Does anyone have an idea how I can solve this problem? I can't find a eclipse plugin called JDT.

  • #2
    TSH,

    I just installed the 3.5M5 release. Before you can install Spring IDE you need to install a recent integration build of WTP 3.1 including all its dependencies. I used the version from this page http://download.eclipse.org/webtools...0090131041147/.

    After that you can install Spring IDE (please don't install the AJDT extension as there is no AJDT version for 3.5 yet).

    HTH

    Christian

    Comment


    • #3
      Thank you. This link is no real update site, is it? I downloaded an archive manually and copied the contents of features and plugins into the appropriate eclipse subfolders.

      The good news: I was able to download and install SpringIDE.

      The bad news: WTP doesn't work as expected. I still have no syntax highlighting etc. when working with JSPs. :-(

      Comment


      • #4
        This link is no real update site, is it?
        No, that is not an update site.

        I downloaded an archive manually and copied the contents of features and plugins into the appropriate eclipse subfolders.
        Did you install all WTP dependencies as well (listed at the top right of the page).

        Christian

        Comment


        • #5
          Cannot satisfy dependency, Spring IDE Core -> Spring IDE Refactoring Support

          i have eperienced following error during my attempt to install the spring ide 2.2.1 from http://springide.org/updatesite to eclipse 3.5 (Version: 3.5.0.v20090611a-9gEeG1HFtQcmRThO4O3aR_fqSMvJR2sJ, Build id: I20090611-1540).
          does anybody know where is the problem and how to proceed?
          thanks.

          Cannot complete the install because one or more required items could not be found.
          Software currently installed: Spring IDE Core (required) 2.2.1.v200811281800 (org.springframework.ide.eclipse.feature.feature.g roup 2.2.1.v200811281800)
          Missing requirement: Spring IDE Refactoring Support 2.2.1.v200811281800 (org.springframework.ide.eclipse.beans.ui.refactor ing 2.2.1.v200811281800) requires 'bundle org.eclipse.pde.ui 0.0.0' but it could not be found
          Cannot satisfy dependency:
          From: Spring IDE Core (required) 2.2.1.v200811281800 (org.springframework.ide.eclipse.feature.feature.g roup 2.2.1.v200811281800)
          To: org.springframework.ide.eclipse.beans.ui.refactori ng [2.2.1.v200811281800]

          Comment


          • #6
            Originally posted by matotuzo View Post
            Cannot complete the install because one or more required items could not be found.
            Software currently installed: Spring IDE Core (required) 2.2.1.v200811281800 (org.springframework.ide.eclipse.feature.feature.g roup 2.2.1.v200811281800)
            Missing requirement: Spring IDE Refactoring Support 2.2.1.v200811281800 (org.springframework.ide.eclipse.beans.ui.refactor ing 2.2.1.v200811281800) requires 'bundle org.eclipse.pde.ui 0.0.0' but it could not be found
            Cannot satisfy dependency:
            From: Spring IDE Core (required) 2.2.1.v200811281800 (org.springframework.ide.eclipse.feature.feature.g roup 2.2.1.v200811281800)
            To: org.springframework.ide.eclipse.beans.ui.refactori ng [2.2.1.v200811281800]
            You will need to install PDE into your Eclipse distributions:

            1. Add this update site or select it from the list of sites if you already have it: http://download.eclipse.org/releases/galileo
            2. Install the "Eclipse PDE Plug-in Developer Resource"

            Then try re-installing Spring IDE.

            Comment


            • #7
              matotuzo,

              please note that Spring IDE 2.2.1 is not compatible with Eclipse 3.5. Please install a more recent milestone build of Spring IDE 2.2.5 from http://www.springsource.com/milestone/e3.4 (the link is correct and working with the update manager).

              This will also remove the dependency to PDE.

              HTH

              Christian

              Comment


              • #8
                Hi,

                I tried to install Spring IDE plugin from the milestone update site you gave us, but I have the following error :

                Cannot complete the install because one or more required items could not be found.
                Software being installed: Spring IDE AJDT Integration (optional) 2.2.5.200906231226-RC1 (org.springframework.ide.eclipse.ajdt.feature.feat ure.group 2.2.5.200906231226-RC1)
                Missing requirement: Spring IDE AOP Visualiser UI 2.2.5.200906231226-RC1 (org.springframework.ide.eclipse.ajdt.ui.visualise r 2.2.5.200906231226-RC1) requires 'package org.eclipse.contribution.visualiser.utils 0.0.0' but it could not be found
                Cannot satisfy dependency:
                From: Spring IDE AJDT Integration (optional) 2.2.5.200906231226-RC1 (org.springframework.ide.eclipse.ajdt.feature.feat ure.group 2.2.5.200906231226-RC1)
                To: org.springframework.ide.eclipse.ajdt.ui.visualiser [2.2.5.200906231226-RC1]
                Any idea ?

                Comment


                • #9
                  You can either add the update site below to satisfy the dependency on AJDT or deselect the Spring IDE AJDT Integration feature in the Integrations category when installing.

                  AJDT update site: http://download.eclipse.org/tools/ajdt/35/update

                  Comment


                  • #10
                    One more problem :

                    Cannot complete the install because one or more required items could not be found.
                    Software being installed: SpringSource Tool Suite (required) 2.1.0.200906231257-RC1 (com.springsource.sts.feature.group 2.1.0.200906231257-RC1)
                    Missing requirement: SpringSource Tool Suite (required) 2.1.0.200906231257-RC1 (com.springsource.sts.feature.group 2.1.0.200906231257-RC1) requires 'net.sourceforge.pmd.eclipse.feature.group 0.0.0' but it could not be found
                    With so many problems I wonder if it's really a good idea to use Spring IDE on Eclipse Galileo for the moment

                    Comment


                    • #11
                      chawax,

                      did you follow the installation instructions outlined in my recent blog at http://blog.springsource.com/2009/06...nto-eclipse-35.

                      This will give you all the required update sites and such to successfully install STS in Galileo.

                      HTH

                      Christian

                      Comment


                      • #12
                        Hi Christian,

                        if you answer a question regarding SpringIDE with a link to the installation instructions of SpringSTS, does this mean that SpringIDE is not available any more?

                        To be more concrete: Is there a possibilty to download SpringIDE for eclipse 3.5 without using the Update Manager?

                        Thanks.

                        Comment


                        • #13
                          Hi there,
                          i had been having a lot of issues installing SpringIDE on eclipse Galileo.
                          I could not see any solutions.
                          BUT FINALLY! I found a WORKING Update link to SpringIDE.
                          I went to http://dist.springsource.com/snapsho...date-sites.xml
                          And found in the xml the Spring IDE Update site :
                          http://dist.springframework.org/snapshot/IDE/nightly

                          The installation doesn't work if you select all the packages.
                          You need to uncheck all the AJDT packages

                          Then It works

                          I hope this wasn't too late.

                          Comment

                          Working...
                          X