Announcement Announcement Module
Collapse
No announcement yet.
Beans Graph is blank or empty Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Beans Graph is blank or empty

    I'm using Rational Application Developer (a.k.a. "RAD") version 7.5.1, which is based upon eclipse 3.4.1. I've successfully installed Spring IDE 2.2.1. The XML editor works, including proper code assit. The Spring Explorer works, properly showing my application contexts, and the beans within.

    However, the visual Beans Graph doesn't work. It does open and no error shows up on the screen nor in the log, but the view is entirely empty and blank -- just a white page.

    I found a similar complaint against an earlier version of eclipse in this thread, but with no meaningful replies (thread #55196, but I can't yet post URLs in this forum).

    I've even re-installed my IDE from scratch and have the same experience. I realize that RAD has a smaller installation based compared to eclipse itself, but every other eclispe plugin I've installed has worked just fine, including others with graph-like visualizations (e.g. m2eclipse's dependency graph).

    Is there anything I can do within Spring IDE to turn on debugging of the plugin itself to shed some light?

  • #2
    Have a look at http[colon][slash][slash]springide.org[slash]project[slash]wiki[slash]SpringideGuide. Maybe you had just selected an unsupported file or xml node within a file:
    1) Select a configuration file
    2) Navigation -> View In -> Spring Explorer. The Spring Explorer opens.
    3) In the Spring Explorer: Right click on one of the beans -> Bean Graph

    Maybe this helps...

    Comment

    Working...
    X