Announcement Announcement Module
Collapse
No announcement yet.
Problem with latest Spring IDE installation on RAD 7 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with latest Spring IDE installation on RAD 7

    Hi All,
    I am trying to install Spring IDE from dist.springframework.org/release/IDE link on RAD 7, but i am getting the following error
    Spring IDE Core (required) (2.2.1.v200811281800) requires plug-in "org.apache.commons.logging".
    Although i am able to use Spring IDE 1.0 by downloading the zip files and installing it from there.

    Also i am not getting any dependency section in the listing of packages, please see the attached screenshot.

    Any pointers on this would be of great help

  • #2
    Originally posted by pankajtiwari View Post
    Hi All,
    I am trying to install Spring IDE from dist.springframework.org/release/IDE link on RAD 7, but i am getting the following error
    Spring IDE Core (required) (2.2.1.v200811281800) requires plug-in "org.apache.commons.logging".
    Although i am able to use Spring IDE 1.0 by downloading the zip files and installing it from there.

    Also i am not getting any dependency section in the listing of packages, please see the attached screenshot.

    Any pointers on this would be of great help
    I have the same problem. Here's my configuration:
    Rational Software Architect (RSA) V7.0.0.7 on WindowsXP

    Something interesting, I see that this plug-in is installed:
    org.apache.commons_logging (1.0.4.v200608011657) "Apache commons logging Plug-in" [Resolved]

    Noticed the "_" in the package name? Is it why Spring-IDE doesn't find it?

    Comment


    • #3
      Eclipse 3.2.2 and therefore RAD 7.0.0.7 is not support by Spring IDE since version 2.2 anymore.

      The amount of work that goes into maintaining compatibility between 3.2, 3.3, 3.4 and now 3.5 is simply to much. Therefore we dropped 3.2 support and will soon drop 3.3 support when 3.5 is out.

      Christian

      Comment


      • #4
        Originally posted by Christian Dupuis View Post
        Eclipse 3.2.2 and therefore RAD 7.0.0.7 is not support by Spring IDE since version 2.2 anymore.

        The amount of work that goes into maintaining compatibility between 3.2, 3.3, 3.4 and now 3.5 is simply to much. Therefore we dropped 3.2 support and will soon drop 3.3 support when 3.5 is out.

        Christian
        Ok then. Until then, what was the latest IDE release that was working on RAD/RSA 7?

        Comment


        • #5
          I got it working using Spring IDE 1.0 from the archieve

          Comment


          • #6
            pankajtiwari,

            Can you provide a location for the Spring ide 1.0?

            I am unable to find it.

            Comment

            Working...
            X