Announcement Announcement Module
Collapse
No announcement yet.
abstract=true error: "Factory method needs class from root or parent bean" Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • abstract=true error: "Factory method needs class from root or parent bean"

    IDE is producing an error for a simple abstract bean, eg:

    Code:
    <bean abstract="true" id="myBean"/>
    Is there some setting (that I haven't been able to find) that needs to be set to support abstract beans?
    Last edited by memelet; Nov 4th, 2008, 03:39 PM.

  • #2
    Barry,

    that sounds like a regression bug to me. What version are you on? Could you file a JIRA for this so I get that fixed for 2.2.1.

    Christian

    Comment


    • #3
      Barry,

      I fixed this problem. Here is the JIRA:

      IDE-946: Validation error on abstract bean
      http://jira.springframework.org/browse/IDE-946

      Thanks for reporting.

      Christian

      Comment


      • #4
        Thanks Christian

        Comment

        Working...
        X