Announcement Announcement Module
Collapse
No announcement yet.
satisfying asm dependency in eclipse 3.4 Ganymede Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • satisfying asm dependency in eclipse 3.4 Ganymede

    Hi there,

    I have been trying to update my spring ide v2.1 installation with the latest nightly but I have not been able to satisfy the following dependency. I already attempted to update my whole eclipse install as well as downloaded the objectweb asm plugin. This match seems to be asking for an exact match. Is it really an exact match or could there be an acceptable range for this bundle?

    Cannot find a solution satisfying the following requirements Match[requiredCapability: org.eclipse.equinox.p2.iu/org.objectweb.asm/[3.0.0.v200803061811,3.0.0.v200803061811]].

    Thanks,
    ub

  • #2
    I would like to share an update on this thread so as to possibly help anyone else who may run into this.

    After many attempts, I decided to start with a fresh eclipse 3.4 and then installed spring ide and spring ap from the nightly downloads. They both worked fine right away SO my big assumption is that I had either screwed up my previous eclipse install OR that there is a bug in resolving dependencies in eclipse somewhere. I say this because those bundles that were listed as required existed in the plugins directory, which to my knowledge indicates that they were available.

    Regards,
    Ussama

    Comment


    • #3
      Problem with dependency of Spring IDE Mylyn Integration

      I had the same problem. Do not install (or remove) Spring IDE Mylyn Integration and it will work.

      Alexandre

      Comment

      Working...
      X