Announcement Announcement Module
Collapse
No announcement yet.
Spring IDE 2.0.6 and Eclipse 3.4 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring IDE 2.0.6 and Eclipse 3.4

    Hello all,

    When I try to install Spring IDE 2.0.6 (core + AJDT + AOP + Mylyn + OSGi + Security + Web Flow) on new Eclipse 3.4.0 (JEE bundle), some dependencies are reported as missing. Here is initial part of error text:

    Code:
    Cannot complete the request.  See the details.
    Unsatisfied dependency: [org.springframework.ide.eclipse.beans.mylyn 2.0.6.v200806241357] requiredCapability: osgi.bundle/org.eclipse.mylyn.ide.ui/[2.3.2,3.0.0)
    Unsatisfied dependency: [org.springframework.ide.eclipse.mylyn 2.0.6.v200806241357] requiredCapability: osgi.bundle/org.eclipse.mylyn.ide.ui/[2.3.2,3.0.0)
    Unsatisfied dependency: [org.springframework.ide.eclipse.aop.mylyn 2.0.6.v200806241357] requiredCapability: osgi.bundle/org.eclipse.mylyn.ide.ui/[2.3.2,3.0.0)
    Unsatisfied dependency: [org.springframework.ide.eclipse.beans.mylyn 2.0.6.v200806241357] requiredCapability: osgi.bundle/org.eclipse.mylyn.context.ui/[2.3.2,3.0.0)
    Unsatisfied dependency: [org.springframework.ide.eclipse.webflow.mylyn 2.0.6.v200806241357] requiredCapability: osgi.bundle/org.eclipse.mylyn.context.ui/[2.3.2,3.0.0)
    Unsatisfied dependency: [org.springframework.ide.eclipse.mylyn 2.0.6.v200806241357] requiredCapability: osgi.bundle/org.eclipse.mylyn.context.ui/[2.3.2,3.0.0)
    Unsatisfied dependency: [org.springframework.ide.eclipse.aop.mylyn 2.0.6.v200806241357] requiredCapability: osgi.bundle/org.eclipse.mylyn.context.ui/[2.3.2,3.0.0)
    Unsatisfied dependency: [org.springframework.ide.eclipse.beans.mylyn 2.0.6.v200806241357] requiredCapability: osgi.bundle/org.eclipse.mylyn.monitor.ui/[2.3.2,3.0.0)
    Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.monitor.ui/[2.3.2,3.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.monitor.ui/[3.0.0,4.0.0)] can be satisfied.
    Unsatisfied dependency: [org.springframework.ide.eclipse.beans.mylyn 2.0.6.v200806241357] requiredCapability: osgi.bundle/org.eclipse.mylyn.monitor.core/[2.3.2,3.0.0)
    Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.monitor.core/[2.3.2,3.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.monitor.core/[3.0.0,4.0.0)] can be satisfied.
    Unsatisfied dependency: [org.springframework.ide.eclipse.beans.mylyn 2.0.6.v200806241357] requiredCapability: osgi.bundle/org.eclipse.mylyn.java.ui/[2.3.2,3.0.0)
    Unsatisfied dependency: [org.springframework.ide.eclipse.mylyn 2.0.6.v200806241357] requiredCapability: osgi.bundle/org.eclipse.mylyn.java.ui/[2.3.2,3.0.0)
    Unsatisfied dependency: [org.springframework.ide.eclipse.beans.mylyn 2.0.6.v200806241357] requiredCapability: osgi.bundle/org.eclipse.mylyn.resources.ui/[2.3.2,3.0.0)
    Unsatisfied dependency: [org.springframework.ide.eclipse.webflow.mylyn 2.0.6.v200806241357] requiredCapability: osgi.bundle/org.eclipse.mylyn.resources.ui/[2.3.2,3.0.0)
    Unsatisfied dependency: [org.springframework.ide.eclipse.mylyn 2.0.6.v200806241357] requiredCapability: osgi.bundle/org.eclipse.mylyn.resources.ui/[2.3.2,3.0.0)
    Unsatisfied dependency: [org.springframework.ide.eclipse.aop.mylyn 2.0.6.v200806241357] requiredCapability: osgi.bundle/org.eclipse.mylyn.resources.ui/[2.3.2,3.0.0)
    Unsatisfied dependency: [org.springframework.ide.eclipse.beans.mylyn 2.0.6.v200806241357] requiredCapability: osgi.bundle/org.eclipse.mylyn.context.core/[2.3.2,3.0.0)
    Unsatisfied dependency: [org.springframework.ide.eclipse.webflow.mylyn 2.0.6.v200806241357] requiredCapability: osgi.bundle/org.eclipse.mylyn.context.core/[2.3.2,3.0.0)
    Unsatisfied dependency: [org.springframework.ide.eclipse.mylyn 2.0.6.v200806241357] requiredCapability: osgi.bundle/org.eclipse.mylyn.context.core/[2.3.2,3.0.0)
    Unsatisfied dependency: [org.springframework.ide.eclipse.aop.mylyn 2.0.6.v200806241357] requiredCapability: osgi.bundle/org.eclipse.mylyn.context.core/[2.3.2,3.0.0)
    Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.context.core/[2.3.2,3.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.context.core/[3.0.0,4.0.0)] can be satisfied.
    Unsatisfied dependency: [org.springframework.ide.eclipse.mylyn 2.0.6.v200806241357] requiredCapability: osgi.bundle/org.eclipse.mylyn.ide.ui/[2.3.2,3.0.0)
    Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.ide.ui/[2.3.2,3.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.ide.ui/[3.0.0,4.0.0)] can be satisfied.
    Unsatisfied dependency: [org.springframework.ide.eclipse.mylyn 2.0.6.v200806241357] requiredCapability: osgi.bundle/org.eclipse.mylyn.context.ui/[2.3.2,3.0.0)
    Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.context.ui/[2.3.2,3.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.context.ui/[3.0.0,4.0.0)] can be satisfied.
    Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.monitor.ui/[2.3.2,3.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.monitor.ui/[3.0.0,4.0.0)] can be satisfied.
    Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.monitor.core/[2.3.2,3.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.monitor.core/[3.0.0,4.0.0)] can be satisfied.
    Unsatisfied dependency: [org.springframework.ide.eclipse.mylyn 2.0.6.v200806241357] requiredCapability: osgi.bundle/org.eclipse.mylyn.java.ui/[2.3.2,3.0.0)
    Unsatisfied dependency: [org.springframework.ide.eclipse.mylyn 2.0.6.v200806241357] requiredCapability: osgi.bundle/org.eclipse.mylyn.resources.ui/[2.3.2,3.0.0)
    Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.resources.ui/[2.3.2,3.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.resources.ui/[3.0.0,4.0.0)] can be satisfied.
    Unsatisfied dependency: [org.springframework.ide.eclipse.mylyn 2.0.6.v200806241357] requiredCapability: osgi.bundle/org.eclipse.mylyn.context.core/[2.3.2,3.0.0)
    Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.context.core/[2.3.2,3.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.context.core/[3.0.0,4.0.0)] can be satisfied.
    Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.ide.ui/[2.3.2,3.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.ide.ui/[3.0.0,4.0.0)] can be satisfied.
    Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.context.ui/[2.3.2,3.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.context.ui/[3.0.0,4.0.0)] can be satisfied.
    Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.monitor.ui/[2.3.2,3.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.monitor.ui/[3.0.0,4.0.0)] can be satisfied.
    Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.monitor.core/[2.3.2,3.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.monitor.core/[3.0.0,4.0.0)] can be satisfied.
    Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.resources.ui/[2.3.2,3.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.resources.ui/[3.0.0,4.0.0)] can be satisfied.
    Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.context.core/[2.3.2,3.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.context.core/[3.0.0,4.0.0)] can be satisfied.
    Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.ide.ui/[2.3.2,3.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.ide.ui/[3.0.0,4.0.0)] can be satisfied.
    Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.context.ui/[2.3.2,3.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.context.ui/[3.0.0,4.0.0)] can be satisfied.
    Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.monitor.ui/[2.3.2,3.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.monitor.ui/[3.0.0,4.0.0)] can be satisfied.
    Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.monitor.core/[2.3.2,3.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.monitor.core/[3.0.0,4.0.0)] can be satisfied.
    Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.resources.ui/[2.3.2,3.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.resources.ui/[3.0.0,4.0.0)] can be satisfied.
    Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.context.core/[2.3.2,3.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.context.core/[3.0.0,4.0.0)] can be satisfied.
    Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.ide.ui/[2.3.2,3.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.ide.ui/[3.0.0,4.0.0)] can be satisfied.
    Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.context.ui/[2.3.2,3.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.mylyn.context.ui/[3.0.0,4.0.0)] can be satisfied.
    ...
    Obviously some part of (Mylyn) plugin is missing. In all update sites available by default in Eclipse 3.4, there is no (Mylyn) plugin feature that would suggest its the one that is missing - I believe Eclipse would have automatically find this dependency if it was in some of the available update sites. Maybe feature in question is not yet available at all.

    Question is, which, if any, update site has to be added so that Spring IDE can be installed?

  • #2
    Just read http://forum.springframework.org/showthread.php?t=47760

    Comment


    • #3
      Eclipse 3.4 has Mylyn 3.0 and SpringIDE uses Mylyn 2.0.6. So you need to uncheck all the Mylyn integration stuff under SpringIDE and you should be good to go. Hope this helps

      Edit:
      copied from another post (since I don't have 15 posts yet, I couldn't link to another post so I improvised)

      Basically this is because Spring IDE 2.0.5 does not support Mylyn 3.0 that comes with latest Eclipse Ganymede RC builds. The only work-around is to not install the Spring IDE Mylyn Integration.

      To get back the Spring Mylyn integration you need to wait till we have ported Spring IDE to the latest Mylyn API. This is expected to happen in early July.

      Christian
      Last edited by cmattmiller; Jun 27th, 2008, 02:49 PM.

      Comment

      Working...
      X