Announcement Announcement Module
Collapse
No announcement yet.
Are there any newer versions for Spring-IDE available? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Are there any newer versions for Spring-IDE available?

    Hi,
    are there any plans to release Spring-IDE with more recent springframework-implementations built in (it still sticks with 1.0.3 and we are now at 1.0.5 or 1.2rc1? Actually what I would need is a Spring-IDE supporting spring-1.2rc1 because of the hibernate3 support :wink: . Or did I just miss the fact that there is a unstable eclipse update site, too?
    Thanks,
    Gernot

  • #2
    Hi,
    i need to know something similar to your question.
    If I install that IDE and wishes to use a newer Spring version than the one which is shipped, how can i do that?
    I saw, there is a Spring core file, if I replace this by a newer one, does it work then?

    Comment


    • #3
      Re: Are there any newer versions for Spring-IDE available?

      Originally posted by stocker
      Or did I just miss the fact that there is a unstable eclipse update site, too?
      Indeed, there is a "unstable eclipse update site" available ;-)
      It's http://springide-eclip.sourceforge.net/updatesite/

      Here you can find newer versions which are not officially released yet. Maybe you can give the latest version (v1.1.1) a try. It supports Spring v1.1.5.
      For details refer to http://springide.org/project/milestone/Release%201.1.1

      This is a development version for internal testing. If you find any bugs please add a ticket via http://springide.org/project/newticket

      Cheers,
      Torsten

      Comment


      • #4
        Originally posted by chainsaw
        If I install that IDE and wishes to use a newer Spring version than the one which is shipped, how can i do that?
        I saw, there is a Spring core file, if I replace this by a newer one, does it work then?
        No, Spring IDE is built on top of a specific version of spring-core.jar. It extends some of's Spring's internal classes and overwrites methods, e.g. org.springframework.beans.factory.xml.DefaultXmlBe anDefinitionParser.

        Cheers,
        Torsten

        Comment


        • #5
          Re: Are there any newer versions for Spring-IDE available?

          Originally posted by stocker
          Hi,
          are there any plans to release Spring-IDE with more recent springframework-implementations built in
          A new version of Spring IDE with support for Spring 1.1.5 is availabe. Please refer to the corresponding announcement http://forum.springframework.org/viewtopic.php?t=4808

          Cheers,
          Torsten

          Comment

          Working...
          X