Announcement Announcement Module
Collapse
No announcement yet.
JavaConfig support Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • JavaConfig support

    I tried using the new Spring Java Configuration library to create a few beans. My project works (I am able to access and instantiate beans defined in the class file with @Bean annotations), but I cannot see these beans in the Spring / Project Explorer views as mentioned in this blog entry: http://springide.org/blog/2007/05/18...ng-javaconfig/

    In my XML configuration file, I have defined a simple bean pointing to the Java class and I have also defined a configuration post processor bean, so my XML file looks similar to this:

    <bean id="config" class="blog.javaconfig.JavaCfg" />
    <bean id="processor" class="org.springframework.config.java.process.Con figurationPostProcessor" />

    If I expand the node for this configuration file in the Spring Explorer view, I see these two beans but none of the beans defined in the JavaCfg class.

    I tried this in STS RC1 and in SpringIDE 2.0.4 + Europa-J2EE.

    Everything else seems to work and I do have 2 Spring IDE javaconfig plugins loaded.

    Any ideas if I'm doing something wrong or if additional configuration is required?

    Thanks.

  • #2
    Hi,

    I assume that you use the latest milestone of Spring JavaConfig. Please note that Spring IDE's JavaConfig support has not been adjusted to JavaConfig M3 yet. The JavaConfig team is currently refactoring the code to make it more tool friendly. Once that is done Spring IDE will adjust to the new API.

    Sorry for that inconvenience.

    Christian

    Comment


    • #3
      Christian,

      Sorry I forgot to mention this upfront, I tried both JavaConfig 1.0M3 and 1.0M2, neither worked for me.

      I appreciate the prompt response,
      Brian.

      Comment


      • #4
        Originally posted by infernalproteus View Post
        I tried both JavaConfig 1.0M3 and 1.0M2, neither worked for me.
        Hi Brian,

        Thanks for the report. I just tried a similar scenario against Spring IDE 2.0.4 and JavaConfig m2a and found the same. I've submitted a new bug report for this at http://jira.springframework.org/browse/IDE-856. Christian is aware of this - you may want to visit the link above and add yourself as a 'watcher' on the issue in order to be notified of updates as they occur.

        - Chris

        Comment


        • #5
          fixed, thanks

          Thanks Chris, I noticed Christian fixed it and it seems to be working just fine in the recent nightlies.

          On a side note, there are some "interesting" links in the Blogroll section of the SpringIDE blog, you might want to get those fixed.

          Thanks again,
          Brian.

          Comment


          • #6
            Brian,

            thanks for confirming that the fix works for you.

            I fixed the blogroll as well. Wordpress seams to pretty vulnerable. Thanks for reporting this.

            Christian

            Comment

            Working...
            X