Announcement Announcement Module
Collapse
No announcement yet.
CommonAnnotationBeanPostProcessor not found ? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • CommonAnnotationBeanPostProcessor not found ?

    I see this error in eclipse 3.3, running springide 2.0.2

    Class org.springframework.beans.factory.annotation.Commo nAnnotationBeanPostProcessor not found on a line :

    <context:annotation-config/>

    but runs ok as it has been moved to:

    org.springframework.context.annotation.ommonAnnota tionBeanPostProcessor

    in 2.5

    not a big deal(as it is just an editor plugin issue where there are other false alarms in other part of eclipse) but can it be fixed ?

  • #2
    Hi,

    this should indeed be fixed. Can you please open a JIRA at http://springide.org/jira.

    But to actually fix it, we need to change some code in Spring core.

    Can you please check what versions of the org.springframework.spring and org.springframework.bundle.spring are in your plugin directory.

    Christian

    Comment


    • #3
      How do I check these "org.springframework.spring and org.springframework.bundle.spring " thing ?

      I experiment a bit by disabling something(the OSGi and Mylyn something) and the error disappeared. though not sure if it is because the checking is disabled or something else.

      EDIT:
      strange. I see 2 org.springframework.source_* in my plugin directory,

      org.springframework.source_2.0.1.v200708152145
      org.springframework.source_2.0.2.v200712142013

      But don't any bundle thing.
      Last edited by garyng; Dec 23rd, 2007, 10:27 PM.

      Comment

      Working...
      X