Announcement Announcement Module
Collapse
No announcement yet.
Problems with version 2.0.2 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with version 2.0.2

    Hi,

    I made an update from 2.0.1 to 2.0.2. and got an internal error "Loading model content". The log says:
    java.lang.NoClassDefFoundError: Could not initialize class org.springframework.core.CollectionFactory
    I guess SpringIDE doesn't find Spring. So how do I tell SpringIDE where to find Spring? (The Buildpath already contains Spring-jars)

    regards

    Steve

  • #2
    Have you tried a clean install? I.e. remove 2.0.1 and reinstall 2.0.2. (Or disable 2.0.1 and install 2.0.2 in another location).

    Comment


    • #3
      Originally posted by mdeinum View Post
      Have you tried a clean install? I.e. remove 2.0.1 and reinstall 2.0.2. (Or disable 2.0.1 and install 2.0.2 in another location).
      No, I just installed the 2.0.2 version and afterwards uninstalled the disabled 2.0.1 jars. I will try to remove 2.0.2 complete and reinstall it.

      Comment


      • #4
        After reinstalling I got the same error. I already removed my old settings from .metadata and the project but that doesn't help anything.

        Comment


        • #5
          This is the same problem I am seeing in http://forum.springframework.org/showthread.php?t=47595.

          Comment


          • #6
            I just installed a fresh 3.4-M4 and am seeing the same problem. So the problem does not appear to be related to leftover crud issues.

            -barry

            Comment


            • #7
              Originally posted by memelet View Post
              This is the same problem I am seeing in http://forum.springframework.org/showthread.php?t=47595.
              I installed everything but the backward-compatibility feature. Im running Eclipse 3.3.1.1 and it is started with JDK 1.6.0_02.
              I'm now back to version 2.0.1, which works perfectly without doing anything special.

              Comment


              • #8
                I installed everything but the backward-compatibility feature. Im running Eclipse 3.3.1.1 and it is started with JDK 1.6.0_02.
                I'm now back to version 2.0.1, which works perfectly without doing anything special.
                You can go ahead and install 2.0.2 including every feature (esp. the OSGi integration feature needs to be installed) besides the backward-compatibility that is only meant for Eclipse 3.2. That should solve the problems observed here.

                For more information see this posting http://forum.springframework.org/showthread.php?t=47595.

                HTH,

                Christian

                Comment


                • #9
                  Loading Model content fails

                  Hi,
                  i have the same problem, but with all optional plugins installed!

                  When starting Eclipse i get the following errors (two times):
                  An internal error occured during:"Loading model content".
                  Could not initialize class org.springframework.core.CollectionFactory

                  and additionally a
                  java.lang.NoClassDefFoundError

                  I had first the problem, that after updateing from 2.0.1 to 2.0.2 the webflow feature was not installed, so i removed the old versions as told as bugfix workaround and did a new installation.

                  Uli

                  Comment

                  Working...
                  X