Announcement Announcement Module
Collapse
No announcement yet.
2.0.2 rc1 - cannot run tests anymore... Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2.0.2 rc1 - cannot run tests anymore...

    After upgrading, when running tests I get the below error. Is spring-ide looking for the spring jars somewhere? If spring-ide is looking in the eclipse project classpath for spring-agent.jar, we rename that jar to spring-agent-2.5.jar. Could that be the problem?

    ---
    Error occurred during initialization of VM
    agent library failed to init: instrument
    Error opening zip file or JAR manifest missing : path/to/spring-agent.jar
    ---

    -barry

  • #2
    When I run the test in the debugger, I can see that the invocation command contains:

    Code:
    -javaagent:path/to/spring-agent.jar
    I'm supposing that spring-ide plugin dynamically adds this, as the launch target does not not define it.

    If this is assumption is true, how do I tell spring-ide where the actual spring-agent.jar is located?

    thanks!

    -barry

    Comment


    • #3
      I'm supposing that spring-ide plugin dynamically adds this, as the launch target does not not define it.
      That is not the case. Spring IDE does have nothing to do with the spring-agent.jar addition to the launch command. There is no such functionality build into Spring IDE.

      Christian

      Comment


      • #4
        Hmm, ok. I thought it would be a pretty good feature, so I assumed ;-) I'll have to figure out what is happening then.

        thanks!

        Comment


        • #5
          status

          * Disabled spring-ide plugin
          * Created a fresh eclipse workspace (from the same checked out code)
          * Was able to run all tests
          * Enabled spring-ide, restarted eclipse

          Now the tests no longer run.

          Attached is the eclipse error log, but here is one exception:
          Code:
          !ENTRY org.springframework.ide.eclipse.core 4 2 2007-12-18 10:50:28.552
          !MESSAGE Problems occurred when invoking code from plug-in: "org.springframework.ide.eclipse.core".
          !STACK 0
          java.lang.NoClassDefFoundError
          	at org.springframework.core.CollectionFactory.class$(CollectionFactory.java:64)
          	at org.springframework.core.CollectionFactory.<clinit>(CollectionFactory.java:89)
          	at org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.<init>(DefaultSingletonBeanRegistry.java:86)
          	at org.springframework.beans.factory.support.FactoryBeanRegistrySupport.<init>(FactoryBeanRegistrySupport.java:40)
          	at org.springframework.beans.factory.support.AbstractBeanFactory.<init>(AbstractBeanFactory.java:146)
          	at org.springframework.ide.eclipse.beans.core.DefaultBeanDefinitionRegistry.<init>(DefaultBeanDefinitionRegistry.java:72)
          	at org.springframework.ide.eclipse.beans.core.internal.model.BeansConfig.readConfig(BeansConfig.java:707)
          	at org.springframework.ide.eclipse.beans.core.internal.model.BeansConfig.getBeans(BeansConfig.java:445)
          	at org.springframework.ide.eclipse.aop.core.internal.model.builder.AnnotationAspectDefinitionBuilder.parseAnnotationAspects(AnnotationAspectDefinitionBuilder.java:158)
          	at org.springframework.ide.eclipse.aop.core.internal.model.builder.AnnotationAspectDefinitionBuilder.doBuildAspectDefinitions(AnnotationAspectDefinitionBuilder.java:90)
          	at org.springframework.ide.eclipse.aop.core.internal.model.builder.AbstractAspectDefinitionBuilder.buildAspectDefinitions(AbstractAspectDefinitionBuilder.java:113)
          	at org.springframework.ide.eclipse.aop.core.internal.model.builder.AopReferenceModelBuilder.buildAopReferencesForFile(AopReferenceModelBuilder.java:375)
          	at org.springframework.ide.eclipse.aop.core.internal.model.builder.AopReferenceModelBuilder.buildAopModel(AopReferenceModelBuilder.java:109)
          	at org.springframework.ide.eclipse.aop.core.internal.model.builder.AopReferenceModelBuilder.run(AopReferenceModelBuilder.java:482)
          	at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:1798)
          	at org.springframework.ide.eclipse.aop.core.builder.AopReferenceModelProjectBuilder.build(AopReferenceModelProjectBuilder.java:69)
          	at org.springframework.ide.eclipse.core.internal.project.SpringProjectContributionManager$1.run(SpringProjectContributionManager.java:91)
          	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
          	at org.springframework.ide.eclipse.core.internal.project.SpringProjectContributionManager.runBuilder(SpringProjectContributionManager.java:99)
          	at org.springframework.ide.eclipse.core.internal.project.SpringProjectContributionManager.build(SpringProjectContributionManager.java:66)
          	at org.eclipse.core.internal.events.BuildManager$2.run(BuildManager.java:629)
          	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
          	at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:166)
          	at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:197)
          	at org.eclipse.core.internal.events.BuildManager$1.run(BuildManager.java:249)
          	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
          	at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:252)
          	at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:214)
          	at org.eclipse.core.internal.events.BuildManager.build(BuildManager.java:356)
          	at org.eclipse.core.internal.resources.Project.internalBuild(Project.java:508)
          	at org.eclipse.core.internal.resources.Project.build(Project.java:94)
          	at org.eclipse.debug.core.model.LaunchConfigurationDelegate.buildProjects(LaunchConfigurationDelegate.java:391)
          	at org.eclipse.debug.core.model.LaunchConfigurationDelegate.buildForLaunch(LaunchConfigurationDelegate.java:117)
          	at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:725)
          	at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:607)
          	at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(DebugUIPlugin.java:826)
          	at org.eclipse.debug.internal.ui.DebugUIPlugin$7.run(DebugUIPlugin.java:1029)
          	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

          Comment


          • #6
            Guys,

            that seams to be a JDK version and class problem. What version of the JDK are you using to run Eclipse and for the project?

            Can I also please get a complete log file showing the error from the start of a Eclipse instance? Furthermore can you everyone please verify that the org.springframework.osgi.backport.util.concurrent plugin is installed (that comes with the Spring IDE OSGi Extension (optional) feature).

            Thanks

            Christian
            Last edited by Christian Dupuis; Dec 18th, 2007, 05:39 PM.

            Comment


            • #7
              Originally posted by Christian Dupuis View Post
              Guys,
              Furthermore can you everyone please verify that the org.springframework.osgi.backport.util.concurrent plugin is installed (that comes with the Spring IDE OSGi Extension (optional) feature).
              That was it! Thanks Christian.

              -barry

              Comment


              • #8
                Unable to get Spring IDE 2.0.2 installed on Eclipse Europa

                Sorry. I post it in a wrong place.

                Comment


                • #9
                  Error opening zip file or JAR manifest missing

                  I was also having this problem, as it turns out this can be a bit mis-leading.
                  You will also get this error message if the jar file doesn't exist. So be sure to check
                  if you have given the correct path and jar file name.

                  In my case the path was incorrect, i fixed that and the problem went away. I then
                  went back and added X to the jar name and got the same message.

                  Hope this helps ...

                  Code:
                  Error opening zip file or JAR manifest missing : lib/spring-agentX.jar
                  Error occurred during initialization of VM
                  agent library failed to init: instrument

                  Comment

                  Working...
                  X