Announcement Announcement Module
Collapse
No announcement yet.
Referenced bean '...' not found Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Referenced bean '...' not found

    Hi,

    I'm using IDE 2.0.2 and it shows the problem "Referenced bean '...' not found" when the bean is defined in another XML file, although all XML files are defined as spring config files for the project.

    Is this a known issue?

    Thank you.

  • #2
    You need to create a config-set containing the xml files which belong together. Then the references should be resolvable.

    Regards,
    Andreas

    Comment


    • #3
      Ha! Make it right and it works
      Thanks alot!

      Comment


      • #4
        Do you have a example to configure this file? I have two files, a config-security.xml and a config-context.xml. In my config-security.xml I have:
        <remember-me key="lint[nUrl+mig~pEers]rUng62" services-ref="ipTokenBasedRememberMeServicesBean" />

        and in my config-context.xml I have:
        <bean class="com.alcaldia.digital.security.IPTokenBasedR ememberMeServices" id="ipTokenBasedRememberMeServicesBean">
        <property name="key"><value>lint[nUrl+mig~pEers]rUng62</value></property>
        <property name="userDetailsService" ref="userService"/>
        </bean>

        but the IDE eclipse show in config-security.xml this warning:
        Referenced bean 'ipTokenBasedRememberMeServicesBean' not found [config set: appDigital/web-context]

        what Can I do?

        Comment

        Working...
        X