Announcement Announcement Module
Collapse
No announcement yet.
Workspace builds very slow since adding in Spring IDE Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Workspace builds very slow since adding in Spring IDE

    I have a large workspace with probably over 100 Spring context files and a similar number of web flows.

    I am finding that a long time is spent in the build doing steps like this:

    validating element action (626) with rule action rule. Each step seems to take about half a second.

    Is this a known problem ? Needless to say building a workspace takes ages at the moment.

  • #2
    Paul,

    there is a very similar issue already in our JIRA. See http://springide.org/jira/browse/IDE-704 for more details. Can you please follow the instructions outlined in the issue and attach a thread dump to see if you observe the same problem...

    Furthermore try to disable both action validation rules to see if this helps.

    Christian

    Comment


    • #3
      Originally posted by Christian Dupuis View Post
      Paul,

      there is a very similar issue already in our JIRA. See http://springide.org/jira/browse/IDE-704 for more details. Can you please follow the instructions outlined in the issue and attach a thread dump to see if you observe the same problem...

      Furthermore try to disable both action validation rules to see if this helps.

      Christian
      Thanks, I've looked at the Jira and the problem does seem very similar. I can't work out though how to use jconsole to attach to my eclipse process - I am using RAD 7 which is Eclipse 3.2 based. What port do I use to attach to it ? 8000 as in your cmd file ?

      Comment


      • #4
        Paul, for attaching JConsole you just need to add the following parameter to your Eclipse vm args:

        Code:
        -Dcom.sun.management.jmxremote
        The debug.cmd is actually to attach a remote debugger to a running Eclipse instance.

        Christian

        Comment


        • #5
          Originally posted by Christian Dupuis View Post
          Paul, for attaching JConsole you just need to add the following parameter to your Eclipse vm args:

          Code:
          -Dcom.sun.management.jmxremote
          The debug.cmd is actually to attach a remote debugger to a running Eclipse instance.

          Christian
          Thanks, I will look at this some time but for the moment have just taken off the action rule from the validation.

          We are also finding that the opening of some (seemingly simple) flows take ages (minutes) to open in the graphical editor. Is this a known issue too ?

          Comment

          Working...
          X