Announcement Announcement Module
Collapse
No announcement yet.
installing eclipse plugin Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • installing eclipse plugin

    Hi,
    I am trying to install the Spring IDE plugin in Eclipse 3.2.2 (Build id: M20070212-1330) as described in http://springide.org/project/wiki/SpringideInstall
    and am now having to track down all the dependent libraries.
    I am trying to install the WST but that requires org.eclipse.draw2d.
    Where can I get that from?

    It would be more helpful if the Spring IDE installation instructions listed all required libraries.

    Many thanks,
    Alex

  • #2
    Hi Alex,

    as stated on http://springide.org/project/wiki/SpringideInstall you need to have WTP >= 1.5 installed and WTP has some other dependencies, like Draw2d. You can read about the WTP dependencies on every WTP download page, e.g. http://download.eclipse.org/webtools...-200708291442/:

    These are the prerequisites to install WebTools Platform;. They must be downloaded and installed before the WTP can be installed.

    The Eclipse driver used in this build is eclipse-SDK-3.2.2-linux-gtk.tar.gz. You can find a suitable driver for your platform at here
    The EMF driver used in this build is emf-sdo-xsd-SDK-M200708282030.zip
    The GEF driver used in this build is GEF-SDK-3.2.2.zip
    To make the overall installation procedure more easy, feel free to download the WTP-all-in-one package (listed on the very same page) and install Spring IDE on top of it.

    HTH, Christian

    Comment

    Working...
    X